Installing PureOS inside a Qubes Virtual Machine

I’m running Qubes and want to run PureOS inside a VM.

I’m able to get PureOS to install in the VM, but when I re-start the VM, it doesn’t load PureOS.

What am I doing wrong?

1 Like

I will watch this with interest. I’ve been experimenting with vms in qubes but not pure os. My experience is that this is difficult. I’ve had no luck with ubuntu, zorin or kali. Parrot on the other hand works like a dream out of the box. I’ve posted my problems on all sorts of forums with no luck. Not even for kali.

Im assuming your installing as hvm? What exactly is happening when you try to start the qube? Does it begin to start the qube at all? Are you getting any error messages? What version of qubes because 3 is different to 4 with kali for example.

I dont know Pure, but I’m sensing an added layer of headache to say ubuntu.

1 Like

I was able to get it to work. But I cannot the network to pass thru to the PureOS VM. So far, no luck getting a network connection.

Here’s the settings that worked:
Kernel: none
Mode: HVM

40GB memory allocated
8096MB initial RAM allocated.

I’ve tried every network setting in the Qube, but so far, no luck getting a network.

1 Like

This is the same unsolved issue I have trying to install Kali. I assume that your recreating the network settings from the qubes settings in the pure setting? It sounds like it. You can also try as subnet rather than

I have also had your problem with ubuntu where I couldn’t get it to detect the wifi or network.

I have found it notoriously difficult to get info about this stuff. People come forward and tell you they have done what you’re trying to do but then disappear when you can’t recreate what they supposedly did. Such is the Linux world though I’ve found time and again.

Good luck. Keep us informed.

I finally got the network to work.

First point: I had to re-install Qubes, combining the sys-net & sys-usb into one, so that I could get a USB ethernet working.

The settings that worked on this machine:

USB Ethernet
Manual configuration.
Be sure to enter the network details exactly as the Qube settings shows.
Turn off, “make network available for other users”.

I haven’t tested wifi yet. Ethernet pass thru is what is working. (I avoid wifi whenever possible.)