Intel 512GB s600 NVME no work with Librem Mini v1

This is not a support request, more of a public notice for others who might stumble across this issue.

I tried for many hours yesterday to install Debian on my Intel NVME. The driver would randomly vanish in the middle of the installation, or sometimes wouldn’t be detected at all by the installer. I finally got lucky and installed the OS but it was completely unstable and kept crashing, freezing, and popping up weird messages.

I tried changing Coreboot version, I tried updating the NVME firmware, I tried different kernel parameter settings, nothing would fix the issue. I put the drive back in my main system, where I’ve been using it for months, and the OS installed fine and was stable, I put it back in the Mini, and again it stopped working.

My solution was to switch to a smaller Samsung NVME I have and that one hasn’t given me any issues.

I believe the issue I faced is similar to this one -

If anyone knows a 512GB NVME that has been tested and works with the Mini v1 please let me know.

Did you update your coreboot?

Yes, first thing I did. Then I noticed the issues so tried out several different older versions, no luck, so I updated again to the latest version.