Intel Graphics Card Issue Librem 14v1 Qubes OS R4.1


I have Librem 14v1 with the original 64GB of RAM and 1TB SSD from Purism.

For the last year I have been using Qubes OS R4.0.4 - and that was very smooth experience. This week I have decided to upgrade to R4.1 using clean install.

Qubes Splash screen when entering LUKS password and later in the desktop environment, mouse cursor get fuzzy, draws slowly on the edge of windows when trying to resize.

There is an issue with the graphics card support, but I can’t work out where.

Is there anyone who solved the graphics card issue? If so what was the solution?


PS: resources looked at:

1 Like

Maybe there is something useful in or knowledge associated with: Upgrading Qubes 4.0.4 to 4.1.0 which would appear to be what you are attempting to do.


Hello @irvinewade

Thank you for the link. On the video at 03:05 you can seek LUKS password and input field is pixelated draws slowly. That is the bug that I am talking about.


At first this looks like a small issue, but when I have moved from 4.0.4 to 4.1 - I have noticed Qubes OS is lagging performance.

Was anyone able to fix this?

FYI @david.hamner

With the disclaimer that I don’t run Qubes and hence am unlikely to be able to help … that doesn’t look like “pixelation” (as the term is conventionally used or misused). It looks like a completely broken graphics stack.

1 Like

Exactly! I have now downgraded back to Qubes OS R4.0.4 as on Librem 14v1 it runs more stable.

I have the same problem with LUKS password field, but I just ESC it to text frame buffer.

I don’t have the mouse cursor and window resize problems now. I use dom0 based xfce gui (currently the default). I saw that problem when I tried sys-gui based on fedora-34. I did not try fedora-35 or fedora-36 based sys-gui.

1 Like