Intel PC Bios UEFI does not recognize PureOS Usb

Hi ppl,

Been trying to create a booting USB, using W10, Multiwritter and then Gnome Disk on distinct Pendrive…
ISO get copied but does not get recognized in Bios Boot setup. :face_with_raised_eyebrow: :face_with_raised_eyebrow:

I m used to create linux USB from ISO and working on a multiboot SSD everyday…but creating that PureOS boot is a damn hard stuff to get working - how about a more effective ISO for a future release This present one will probably kill new users in the egg - my 2 cents !

So…what the next way to go then ?

Use a different computer. 1) Almost guaranteed your current hardware won’t be supported by PureOS and 2) PureOS doesn’t support UEFI (last I checked) which you are surely using.

The ISO is trying to do its job. Your computer won’t let it.


Maybe try to change the UEFI boot sequence to ‘legacy mode’ or ‘BIOS mode’ or ‘legacy bios’ or something similar (the label depend on your UEFI) on the computer you want to try it and disable 'secure boot’™

…missing the old good days when UEFI and secure boot didn’t exist and it was so much easier…


Tks ppl,

  • Legacy (storage) didn’t get better detection…
    -.seems pure UEFI is only available on this mini-pc 2015.

…what motherboards models are you guys running P.O. onto ?

grabing another celeron minipc…

Still not working even with old celeron…

I have a doubt :

Could someone run a check on the resulting files from the ISO and burned to a USB ?

I’ve downloaded the ISO file from the webpage yesterday - it looked a bit weird to me coz usualy (ISO burned) resulting files are a bit more than just 1 file and 3 folders + 1 hidden…but I’m no expert…

  • I’ve done the re-burning 3 times and dont get more files each time. Hash was also checked succesfully

something I’d be missing here…or PO comes as it… ?
Tks for the check See pix :face_with_raised_eyebrow: total files from ISO 9 0

Sounds complicated, and therefore prone to failure. It would be surprising to end up with a boot-able drive after that!

I’m giving what might sound like an overly basic answer – if you want a more advanced answer, you’ll have to post technical details of what you tried.

Normally, for a pen drive to be boot-able, its contents have to be a byte-by-byte identical copy of the ISO. For that, you don’t usually want to use any fancy tools that will “helpfully” make modifications to the ISO.

The most common error is to copy the ISO to a partition, instead of to the device as a whole. If the ISO is copied to a partition, a computer’s BIOS won’t recognise it as something that’s meant to be booted.

The standard procedure is to use dd, the most straightforward duplication tool I know of. However, you’d need to run it from a unix-flavoured operating system (Linux, macOS, or BSD; I don’t know whether or not Windows Subsystem for Linux will do it).

sudo dd bs=4M if='<path-to-ISO>' of=/dev/<target-device> status=progress && sync

Where <path-to-ISO> is going to be something like /home/username/Downloads/pureos-9.0-gnome-live_20200806-amd64.hybrid.iso

And <target-device> will be something like sdb or sdc, whatever your computer decides to name your USB thumb drive at the moment. WARNING: Be super careful here and triple-check that you’ve correctly selected the USB thumb drive and not something important, such a hard drive or SSD. It’s with good reason that people joke that dd stands for “Disk Destroyer” or “Data Deleter” – dd will overwrite much of the data that’s on the target device!

If you’re stuck on Windows, an alternative to using dd is the app “Etcher” [1]. I’ve never tried it.

Be sure to try both the “OEM” and “live” versions of the ISO [2, 3]. If I remember correctly, one of the versions (I forget which is which) expects a specific hardware configuration that’s common to all Purism hardware, but is becoming rare in most other modern PCs.

As @fralb5 mentioned above, if your PC’s motherboard uses “UEFI Secure Boot”, you may or may not be out of luck. If it does, it’s worth checking you motherboard’s documentation whether “Secure Boot” can be turned off, or, alternately, “Legacy Boot” can be turned on.




1 Like

Could you just confirm that the Usb drive only contain what is shown on the above capture or are there other files at the root of it ?

Yes, the file hierarchy on my USB drive is identical to yours.
But that’s irrelevant, because it sounds like your computer’s BIOS isn’t getting as far as looking for a filesystem.
Use whatever disk utility you have available to check the partition map of your USB drive. (In Linux, fdisk -l or parted -l will work; in macOS, diskutil list; in Windows, I’m not sure what tools are available)
My USB drive has a modified legacy MBR partition table, followed by a 1.4 GB hidden partition with a boot flag set. Some utilities show that the hidden partition is in ISO 9660 format. It should work with any PC that allows legacy boot. UEFI-only PCs might not recognise it, since the ISO would have needed to have been specifically set up to work with UEFI.
If you have a UEFI-only motherboard and the ISO isn’t UEFI-compatible, installing PureOS will take a few extra steps. I haven’t followed this through to completion myself, but what I think you can do is format a USB thumb drive with a GPT partition table, and set it up to be UEFI-bootable. Then you can copy over the directories and files you listed and use the USB drive as your install media. Getting it right probably takes patience and a deep dive into the documentation.

1 Like

On Windows you can prepare your USB using “HP usb format tool” its a free utility easy to find online and very usefull making your USB bootable.
On linux I most only do everything with Gparted.
…I kept using the same pendrives to install dozens of Linux Distro ISO just this past week and never faced a boot detection problem until I copied the PureOS Iso to it…so it might have corrupted some table somehow…If the BIOS is not involved :frowning:
I’ll test that again,
Tks !

No this will not work. Windows work with UEFI while Linux distributions work with both UEFI and BIOS.
You can’t have though a dual boot system where the one operating system works on UEFI and the other one with BIOS.
Both have to be the same.
Now don’t think that Pure OS doesn’t support UEFI because during my own recent installation the installer gave me two options. One to install in MBR ( that is a BIOS thing) and the other one… well… I don’t know what was the other one but it prompted me to make a 10 mb partition. I assume that this was for the UEFI thing.

Now my problem is that I shouldn’t have add this option on my installation because my other installation that is on another separate disk has been done on legacy mode on an old computer and I just moved the disk from the old computer to the new one.
Though I think that my computer supports both systems I think also that I made a mistake to install PureOS with the 10 mb partition that I don’t remember how it was called but I think that it was for the UEFI support.

Anyway. Whatever is the case with my computer ( I’ll start a new thread) if you intent to install Pure OS along with the Windows then you should install it on UEFI or how else it is called otherwise you will have problems with the boot.

the “other one” being GPT with UEFI. yes PureOS does support that … on Liberated hardware like Purism laptops/minis. otherwise … NOT

want blackbox support ? you have to go somewhere else > Debian/non-free > Ubuntu > Linux-Mint > Arch/non-free > Gentoo/non-free > open-suse/non-free > etc./non-free > Linux/non-free-kernel distributions (whatever they might be named, the non-free support has to be there out of the box in the ISO image or you need to do-it-yourself)

1 Like

Way too complicated!!! I got tired just by reading the instructions on your post! lol
No thank you … I don’t want blackbox support. I’ll live without it!

nothin worked ppl, sorry, wrong hardware… pureos will remain a mistery !
byeeeeeeee…maybe on some future HW !
:crazy_face: :crazy_face: :crazy_face:

I used unetbootin to create the iso image on the usb stick that is available for windows too.
Before using unetbootin though you’ll have to format the usb stick in order to erase everything and empty its .trash folder.
After creating the iso image in the usb stick you have to connect it with the computer, then turn it on and press directly the F12 key in order to get into the pc’s boot order priority menu and make it boot from the usb ports.
This is a bit tricky because if you delay for a second or your keyboard is a bit slow and the computer’s bios is set up to boot from the disks then that is exactly that is going to happen. It will boot from the disks according with the order that you have set it up to boot.

IMO the reason why your computer can’t boot from the USB is that either you haven’t burn properly the iso image ( used the wrong application) or because the pc is not set up to boot first from the USB ports.

P.S Trying different USB ports helps too. You might have one that doesn’t work properly. It is better to use the USB ports that are on the back of your pc and not those on the front if you use a desktop pc of course.

And here is another thing that you should check on your Bios. Check if you have enabled the fastboot. When it is enabled then the pc doesn’t boot from the usb ports.

Don’t worry (and be happy), as this “distinct Pendrive” is so unique that it just won’t boot PureOS (no way). And in addition, every word that @DHS already wrote here was pretty much clear to me.

I’m not worrying. I’m just trying to help as sometimes it is the most trivial and stupid things that prevent us from doing an installation. A minor change in the bios, as f.e that one with the fast boot that skips the usb ports.

i would NOT mess with Fast Boot if i were you … in fact some blackbox BIOS/UEFI motherboards out-there recommend you the same …

I got the same problem.
I first installed PureOS on VirtualBox and well… it looks GREAT. I wanted to install on my laptop and made boot-able USB, but when restart it didn’t show up (I have done this many times before, so I know I am doing this right).
My iso-file is pureos-9.0-gnome-live_20200806-amd64.hybrid.iso
After download a new iso file (older pureos-9.0-gnome-live_20200126-amd64.hybrid.iso) and make new boot-able-USB, still not found. I thought the USB device was damaged, so I got new USB, but nothing. I tried to make the USB with other distro, and that one showed up, so I know it is not the USB (I tested with two USB devices), that’s why I am trying to find a reason for this.
So it must be the UEFI thing. So how can I install this beautiful distro to my laptop. Do I have to use it in a virtual machine (of course it isn’t what I want).
I already have Windows-10, Linux-Mint (my main OS), Solus and Manjaro on my laptop, and have never experience this.
This distro look so nice that I was thinking if I would move from Mint to PureOS, so I would like to find a solution to install it on my laptop.


After some resource I think PureOS cannot be installed on UEFI based computers, so probable I won’t install it on my laptop… :frowning: a little disappointing, but I still have my Linux-Mint. Felt PureOS so nice and promising…

thanks anyway.