Internet Connection with Librem running Qubes 4.0 : Ath9K Driver

I’ve been having issues with maintaining stable Internet connection speeds on my Librem 15 running Qubes 4.0.

It seems that running a rmmod ath9k temporarily resolves the issue.

I’ve tried the following:

-Increasing Available Drive space on the Sys-net & Firewall templates & VM’s

-Adding options ath9k nohwcrypt=1 TO /etc/modprobe.d/ath9k.conf ON both template & VM’s

-Increasing ‘Group Key Rotation Interval’ on the router to 3600

-Disabled IPV6 on the OS Network connection

-Tried 5 GHZ vs 2.4 & changed channels

I have not experienced any similar issues on my Windows OS that I am required to use for work throughout the day.

Any suggestions for additional troubleshooting?

1 Like

Might be worth opening up the laptop and checking the connections on the Wifi card to make sure they are securely fastened. I don’t use Qubes, so I can’t help much there, but I’ve seen other forum posts mentioning Wifi, and adjusting the connectors helped in some cases.

1 Like