Is a HP Pavilion dv7 too old to install PureOS onto it?


#1

Sorry to come off like a n00b here, but I can’t seem to install PureOS on this old laptop.
link to specs
This HP Pavilion dv7-2185dx Entertainment Notebook PC is running with Ubuntu 16.04 LTS right now. I tried to run the USB type PureOS installer on it and what happens is I get past the initial tertiary option list, test/install, test/install (failsafe), and advanced options. I pick the first option but have tried all 3 choices and all lead to the same results. What happens next is I get asked for a Username and then a Password, which I haven’t guessed right yet. It’s none of the users in the Ubuntu OS on it now. That’s where I am stuck.

My installer image is pureos-8.0-gnome-live_20190830-amd64.hybrid.iso and I have tried it both by making the “Start-up Disc” with Ubuntu’s built-in program, then with the Etcher software.

I don’t seem to have any way to start following this set of instructions at Step 1:
https://tracker.pureos.net/w/installation_guide/live_system_installation/


#2

I think the answer is this
Username: pureos
Password: live
But I haven’t tried it myself.


#3

Apparently when you put that username in it skips the password screen. I’m in!


#4

Is a HP Pavilion dv7 too old to install PureOS onto it?

Age isn’t really the challenge. The challenge is drivers.

I have some doubts as to whether the LightScribe will work. Does it work with Ubuntu 16.04?

Ditto re the fingerprint reader?

The WiFi might be the tricky area, although at least you have GbE to get you on the network.

The CPU looks to be fairly old and slow. How well does it perform running Ubuntu? (That won’t stop you installing though.)

Let us know how you go.


#5

Lolz. I found a bunch of new ways to crash the installer; cause PEBKAC and didn’t actually RTFM. Last night I got pulled away during Step 5 and when I came back didn’t know how to get the screen to come back on. I didn’t guess it was also click low and swipe up. (n00b)


#6

Well, I can’t guarantee the hardware is all still functional, but the install finished fine but the machine never loaded it after the reboot. It hung for over an hour at:
[ OK ] Started Modem Manager

I gave up waiting and power button forced another reboot, but now it’s hung earlier in the process on:
[ OK ] Started GNOME Display Manager

The live from USB OS seemed to work fine on the hardware, but theirs a lot I don’t know about the difference between the two. I’m going to try once more from USB boot to see if a different way works better.


#7

I tried it again but did the Master Boot Record partition table instead of GUID Partition Table. It never finished the first boot after install. It froze at the same place as the first try. :cry:


How to install PureOS on a Surface Go