Is Byzantium testable in Boxes under Amber on a librem13?

The title of this post states my question. John

“Boxes”? I had to look it up, I guess you mean this? https://en.wikipedia.org/wiki/GNOME_Boxes

Looks interesting.

Yes, that’s the Gnome virtualization app. It worked fine for me testing Ubuntu 20.04 before I committed to using it on another one of my systems. jaa84

I don’t see why it wouldn’t. Did you try it out?

Should be. Just download the PureOS image from pureos.net, create a VM with that image, and then inside the VM, change /etc/apt/sources.list to move from Amber to Byzantium. Then a sudo apt update && sudo apt upgrade should put the VM on Byzantium.

Thank you for the tip about changing the /etc/apt/sources list.
I’ll post my experience. jaa84

I gave it a try this morning. I was using a PureOS image I downloaded back in March, so it might be older than what’s available now. I did have to manually install some packages that were otherwise being kept back in order to resolve some dependency conflicts, but by the end of it, I got it all upgraded and have a functional, PureOS Byzantium VM in GNOME Boxes 3.38.1 via Flatpak.

1 Like

See this page: https://tracker.pureos.net/w/recommendations/upgrade_from_amber_to_byzantium./

For me, the instructions there worked fine. If I remember correctly there were some packages that were listed as “kept back” but that was resolved by simply doing “apt install” for those. (I think that can happen when packages have added dependencies on new packages, those new packages need to be installed as well and that happens when we do “apt install” for the original package.)

1 Like

If I’m thinking of the correct thing, if you do “apt full-upgrade” it will go ahead and add new packages, whereas “apt upgrade” will not.

1 Like

Here is a summary of my experience running byzantium in Boxes under an up-to-date version of amber on my librem13.

  1. Downloaded the iso from the PureOS download page.
  2. Installed amber in a Boxes VM
  3. edited /etc/apt/sources.list to change all instances of ‘amber’ to’byzantium’
  4. ran ‘sudo update && sudo upgrade’
  5. A LOT of software updates occurred!
    6.in the VM, /etc/os-release still shows ‘version_ID=9.0; CODE_NAME=amber’
  6. in the VM, ran the ‘Software and Update’ tool and after some updates was asked if I wanted to change the home directory of user irc: said yes
  7. A torrent of software updates followed!
    9.restarted the VM, /etc/os-release now shows ‘version_ID=10.0 and CODE_NAME=byzantium’
  8. am now exploring what differences are apparent to me as user.
2 Likes

I think the main changes you will notice is newer versions of all the default, GNOME-related software, as well as just having access to newer versions of most software in the repos.

Yes., that is perfectly possible.

ironically the KDE .iso version of Byzantium from > https://downloads.pureos.net/byzantium/
is more recent than the GNOME one :wink:

still not human-readable @joao.azevedo :stuck_out_tongue: