Is GPS/Geoclue off for you?

I noticed that the Maps app shows my location, but within my app (RepeaterSTART for the locate me button (using GeoClue) centers me on Hong Kong??? I am in USA.

Just wondering if anyone else has noticed this in other mapping apps or has tracked down the bug.

I recommend:

  • configure geoclue to ignore all sources other than GNSS (GPS) e.g. not WiFi and not cellular - that way you are sure where location information is coming from
  • review all existing topics about verifying that your GNSS is initialised properly (downloaded ephemeris) and correctly deriving position information - you may be implying though that this part is working correctly already

Obviously it also depends on the state of your Hardware Kill Switches. For testing purposes you may want WiFi/BT - off; cellular - off; camera/mic - on.

It’s odd, every other time I use the RepeaterSTART locate me button it takes me to that location near Hong Kong.

Worse yet, I noticed if I walk around the neighborhood it doesn’t update the blue dot of the default MAPS app… Is GPS not working at all on Librem5 right now, is it all network based?
And when I leave wifi the whole map turns to “offline” message, it should be showing the last view and a moving dot at the least!

I got same issue like you before but i fixed by a custom geoclue config, so not more king kong locations.
After i configured the geoclue the GNSS worked very solid.
At the moment there are no decent mapping apps for Phosh yet, the only promising mapping apps it is: Mepo :shushing_face:

1 Like

What is this geoclue config - why would GPS not be used first before network?

One answer is: if you are inside a building then GNSS may be unusable (signal too weak / lots of reflections) whereas that is probably where WiFi gives its best results (most likely for there to be a WAP at all, and WAPs don’t move around much).

Even so, if you want to be sure that GNSS is working then you need to ignore / disable other sources of location information (as recommended above).

1 Like

How do you configure L5 to ignore wifi? Is it in the settings or a file in /etc/ ;

About wifi. Something must be wrong here. I am on an island but maps using wifi puts me in Athens, where I guess that Athens is a place where the ISP line passes through. So L5 chooses a wrong point to locate me through wifi.


Thanks @irvinewade I will edit the file.

Still the wifi issue must be solved because as others have said when in a building gps cannot be used for location easily.

Is there a way to specify priority? Like “if no gnss, use WiFi”?

Wlan(aGNSS) it help to GNSS to quick process the g.n.s.s data. So putting to False the Wlan will make that GNSS take the default time that it is 4 minutes to get real location. So in this case something it wrong in the geoclue, that not work good, in that case it better to False all aGNSS.

1 Like

I would say Pure Maps with OSM Scout server is the most developed, since you can basically be offline and still get directions, maps, searches, routing (once GPS works efficiently - aquisition of initial position, download of satellite data etc)

I know the Sailfish-PureMaps but Librem 5 deserve a better gnu mapping client. Seems that Mepo may be.

What did you set in the file to see GPS location - does it work even around zero wifi devices?


Personally, I am wary of ever using WiFi for location - as it involves unpleasant privacy issues. If you are not worried about that then I understand you just want it to work (but in that case for testing you would want to disable using the GNSS and enable only WiFi and really see whether it is working and/or get to the bottom of why it isn’t working).

That was me actually who said that. :wink: With GNSS only and no WiFi then your device would be expected to identify the location at which you entered the building (i.e. last known location) until such time as you leave the building. That won’t be far wrong, depending on how big the building is i.e. should be fine for your house.

There are in-building location systems (besides WiFi) but they are either proprietary or raise even worse privacy issues or both.

I was just using grep on the raw GNSS device, not using geoclue. Yes, it worked (produced plausible coordinates that closely match my iPhone). There’s another topic on doing that.

Enable 3G source

CDMA source configuration options

Enable CDMA source

Modem GPS source configuration options

Enable Modem-GPS source

WiFi source configuration options

Enable WiFi source

1 Like

Thanks for sharing, after an incomprehensible amount of time my phone finally got a fix.
I’ve noticed that it loses the gps signal not only inside buildings but, contrary to all the phone I’ve owned in the last ten years, also in my car, making it virtually useless :worried:


Today I tried to use maps and it still shows me at some other place, the headquarters of the mobile provider (I am with mobile data on).

I checked /etc/geoclue/geoclue.conf
and I have


How can I force only gps location?

I using my L5 with pure GNSS only, so it possible do that.
After config like this REBOOT then wait till 15 minutes till get location.
Purism is working on a new version of gnss-share to rapid get gnss location in L5, not yet shipped.

I’m trying to setup geoclue on the Librem 5 to pull GPS coordinates from a GPS receiver plugged into the USB port. It’s a standard receiver, BU-353S4. So far, this thread has been quite helpful. I’m hoping someone here might have a quick hack to solve my issue.

I turn all forms of GPS off, except for the NMEA, in geoclue.conf. From here, I note that GPS data is incoming using gpsd, which creates the /var/run/gpsd.sock and I can see the data in gpsmon. How do I link up the gpsd.sock to geoclue?

So far, I’ve tried pointing geoclue.conf directly to the gpsd.sock but no luck. I get “Permission denied” when I try to point geoclue to gpsd.sock.

I also tried changing the sock in the /etc/gnss-share.conf file to gpsd.sock (also changing device to /dev/gps0). This was another long shot with no success.

I also added the user to dialout and geoclue groups in the hopes of getting the permission needed above.

Finally, I found that gnss-share appears to be holding the keys here and is still in development:

Can anyone suggest another option? My hope is to leave the GPS receiver in my car and plug it into the L5 when I’m on the road for a good, solid signal. I know Navit will use gpsd, but it’s clunky. I prefer PureMaps for a lot of reasons. Cheers!