Is Virtualization Supported im QubesOS?

In Windows when you want to install vmware or run hyper-v, you have to go into Bios and enable a flag for it.
So I have Ubuntu running as a hvm in qubesOS. I tries to install docker or something related to docker that wants to run containers and got an error, something about needing to enable virtualization. Any ideas?

How does one go about launching into PureBoot anyways? F8, F10?

I believe there are no BIOS settings but you haven’t said what hardware you are referring to.

Hi, this would be the Librem 14. So no way to enable virtualization? How about on the other desktops you sell with disabled Intel ME?

The Librem 14 has always been tested for QubesOS support, so I can give an almost official statement that it’s either already enabled or possible to enable.

I expect someone on the forum to know a solution to your specific problem.

EDIT: it would help a lot to describe what exactly you’re installing and what error you are seeing exactly. It’s nearly impossible to help you wuth the description so far.

@SnoopPops if Qubes is running on the Librem 14 all the virtualization functions are already working. I think your Problem has something to with nested virtualization within Qubes VMs see

Well that’s glass half empty. Glass half full is: no way to disable virtualization either. :wink:

Nested virtualization makes more sense. Of course virtualization should be enabled being that QubesOS works to begin with, but trying to used Virtualbox and docker within a VM takes it to a deeper level, that’s where I see errors but not done trying.

I can’t think of a good reason to disable it except as a policy rule perhaps if your machine has very limited memory.

The point was really that with no BIOS settings at all, there is no way to either enable or disable virtualization at the machine level. Whatever is is.