Issue formatting Samsung T7

I’m using a Librem 14. I used mkfs in Terminal to try to format a 2TB Samsung T7 SSD to ext4. I let it run over night. It must have run for more than 4 hours (less than 12). I received the following message at the end:
Writing superblocks and filesystem accounting information: mkfs.ext4: Input/output error while writing out and closing file system

I intend on using this external drive as my backup location. I will use the Déjà Dup Backups application in PureOS to perform my backups to this drive.

Can anyone provide any recommendations for getting this formatted? Does this just happen every once in a while and I just need to try again? Is there a better, more reliable way to format the drive? I’m fairly low on the Linux learning curve. So, keep that in mind. Thank you.

You’ll need to create new partition table as a first step … as mkfs.ext4 step is the last one there. You might choose to use Disks application for preparing your Samsung T7. Or type within your Terminal app: sudo fdisk --list and locate Samsung T7 mount point (/dev/XXX). This post should help with your initial step: Talking about Librem 5 in French language. Please change bs=8M to bs=32M and from there use Disks, etc. Let us know if something unclear and/or post here initial sudo fdisk --list output so we can confirm which mount point took your external SSD.

Also, as related and helpful:

Thank you for your reply @Quarnero. I think I will try to use Disks to create a new partition table as you recommend. And, then I will use it to format the disk. I’ll try to follow along in the link you provided:

Also, as related and helpful:

Here are two screenshots of the Disks application on my Librem 14. Is the "Drive Generic STORAGE DEVICE part of the Samsung T7? If so, is that the one I select to start working on partitioning and formating, or do I ignore that one and select the 2.0 TB Disk?

1 Like

So, I think the “Drive Generic STORAGE DEVICE” was left over from when I first plugged in the Samsung T7 and tried formatting it. I powered off both the Drive and the 2.0 TB Disk and they went away. I replugged in the Samsung T7 and only the 2.0 TB Disk showed up :+1:

I then tried creating a partition table. I got an error, but when I tried again with a different cable it worked without issue :+1:

Now to format the disk using the Disks application, can I select the Internal disk for use with Linux systems only (ext4) option even though I’ll be using this as an external backup drive?

1 Like

If you’re only going to use it with a Linux computer then yes.