Issues after updating (internet & system speed)

Hello, I have some issues with my Librem 14 that I recently updated (I think). I say “I think” since I do not know if I’ve done it properly: I typed sudo apt update but nothing really happened but then I typed sudo apt upgrade and I belive that it was then that my system updated. I had trouble updating: when I went to the “Software” app, and went to “updates” and tried downloading them I got an error; I read that you could update your system with the command lines mentioned above. After I typed sudo apt upgrade and waited for everything to fall into place I saw that the background went black and that my VPN stoped working. I restarted the computer but I had some trouble getting it to boot properly, sicne when I started it I would get a red error message (since I started it with the security key plugged in) telling me that a file (I have a vague memory of the file having the word “hub” or “github” in it) had been tampered with. After fiddling around with the menu I think I got the system to run properly. Yet when I started it, the load after I unlock/decrypt the hard drive is way longer than what it used to be: It used to be that I entered the password, saw the little PureOS animation and a few seconds after I would be able to log in. Also, the log in time is equally as bad. After I enter my password, it takes about the same time to access my desktop as it took to access the login menu; much longer than what it used to be. Also, now my internet doesn’t work anymore. I use ethernet, and I do not have a wifi card, yet it doesn’t work. The computer says that I’m connected but I can’t access it. I tried ping and ping but the responce I got was ping: Name or service not known which is the same message I get when I do the same command without an ethernet connection. And the same issue is present when I try to connect to my VPN or TOR: it doesn’t.

I am new to Linux and PureOS so I a not that fammiliar with all the commands needed. But I’m sure that what happened, happened because I updated my computer. I am not sure if there’s any troubleshooting I could do to fix this… still…

Has this issue happened to anybody else? Because I’d like to think that it happened after I updated my system and that i just need to wait for a new update… but how would i do that if I do not have internet access?

Please help!

[edit:It’s probably not my ethernet cable since it worked well with a diffrent device, perhaps it’s the port?]

I think I fixed it… I often just press ctrl + alt + del to shut down my computer but this time I just closed the lid, waited an hour or so and opened it back up (this time I didn’t have to decrypt my hardrive, I just log-in). And this time, I could access the internet via the default “web” app. The time it took to decrypt my hardrive and login to my account were as they were before, meaning that that it didn’t take several minutes to log-in. If you had the same issue as I did, you should try to just close your computer lid, wait a bit and open it up again, this worked for me, could also work for you. I also uninstalled my VPn, so perhaps that might be your issue if you have a VPN. I think that it’s back to normal now.