Kernel panic after recent update

After telling my librem13 to go ahead and restart and install this update today. It won’t restart.
When I switch off and then on I get the blue screen that offers me a choice of which thing to boot in. I’ve only tried the default PureOS GNU-Linux (the alternatives seem to all be various kinds of memory test). and that just gets me a black screen with Kernal panics. Any advice?

1 Like

1 Like

The first two lines about temperature arn’t showing up now. But the rest is the same after the third restart. C

I am running into the same issue.

For what it’s worth, a workaround to make your laptop usable right now is to boot the pre-update version of the kernel: In the blue bootloader screen, along with the default PurismOS and the memtest options, there is an “Advanced options” entry. Go there and select PureOS with kernel 4.14.0-3 (no need to do recovery mode, this should be the third entry from the top if you just installed the faulty update) and that will be your OS as it was before the update (at least the kernel).

That said, this is kind of a blunder for a kernel update for an OS that ships with the hardware… I hope there is an official fix and/or communication from Purism forthcoming on this one. Not the best first system update experience, even as an experienced Linux user :slight_smile:

In case it is useful to anyone at Purism troubleshooting this issue: I have a stock Librem 13 v3. I can get any other data you guys need or help debugging this, if it’s not trivial to repro in the same machine model.

1 Like

Yup that, did the trick.
Many thanks. I’m not an experienced linux user and am used to having laptops that can cope with their own updates.
I’ve lost all my websites in the Pure Browser though. That’s been set back to factory settings.

This is being tracked here:

I’ve lost all my websites in the Pure Browser though. That’s been set back to factory settings.

(That sounds unrelated, alas…)

Yup that, did the trick.

@ChrisD, could you let me know which kernel version you selected in GRUB menu? @uuid seemed to get it to work with 4.14.0-3, but it would be good to know which you used…

blunder for a kernel update for an OS that ships with the hardware

This is a new, transient, issue … but we are on it.

blunder for a kernel update for an OS that ships with the hardware

This is a new, transient, issue … but we are on it.

Sorry, didn’t mean to be too mean about it. I understand that you can’t have the QA setup that say Apple does, and even they get it horribly wrong from time to time, it’s just that boot errors on their shinny new laptop are extra scary for most users :slight_smile:

Again, if you don’t have a device that repros this well, my laptop does so consistently and I’d be happy to run tests on it when I have a moment, up to installing .debs or building a custom kernel (but probably not gdb-ing the kernel), or get you any info you need from command line output. Let me know and I’ll make an account on that Phab instance.

Sorry, didn’t mean to be too mean about it.

Wasn’t read as such, don’t worry. And you make some excellent points. Just waiting for @ChrisD to get back to me?

Hiya, I followed UIIDs advice but I didn’t take a photo so I have no clue which set of numbers it was now. Definitely not the recovery option, but the option above that one. What UIID said.

Sorry, I meant UUID.

Can you run uname -a for me? :slight_smile:

linux libremCD 4.14.0-3-amd64 #1 SMP Debian 4.14.13-1 (2018-01-14) x86-64 GNU/Linux

Also while trying to drag an attachement onto an e-mail (to attach it) I wound up with the pointy finger of doom, i.e. things pretty much crashed. e.g. I could click to close an e-mail, but I couldn’t select any of the options (save, cancel etc) but could only close the dialogue window.

Then when I restarted I had the whole kernal panic thing again and had to repeat the instructions above.
Would appreciate any fixes.

@ChrisD Can you also provide the output of sudo update-grub. Just want to confirm the broken/working kernel versions. :slight_smile:

Backup also stopped working and I had to enter ‘Sudo dpkg --configure -a’ to get it to work.

How do I copy paste the tilix output?

[sudo] password for [myname]:
Generating grub configuration file …
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.16.0-1-amd64
Found initrd image: /boot/initrd.img-4.16.0-1-amd64
Found linux image: /boot/vmlinuz-4.14.0-3-amd64
Found initrd image: /boot/initrd.img-4.14.0-3-amd64
Found memtest86+ image: /memtest86+.bin
Found memtest86+ multiboot image: /memtest86+_multiboot.bin

By the way, assume this is unrelaetd, as I happened before the update that lead to the kernal panics. Or perhaps it’s related? It happened on Friday and today/Monday, with the update occuring on Saturday.

Sometimes, particularly after I’ve tried to drag and drop something, The mouse pointer is locked onto the pointy finger symbol and most functionality is lost. For example I can open activities, open R studio, type in 1+1, but then hitting enter does not work and r remains as it is and can’t return 2.
Or I can try to close an e-mail, it will bring up the dialogue to ask if I want to save it or cancer etc, but i can’t actually select anything, I can only close the dialogue window.
the only cure is to restart.
So I mentioned it above, but adding it again with more detail here. Do you tihink it’s the same problem or a separate problem?

So, is it safe to sudo apt update && sudo apt full-upgrade yet?
I’ve been holding off since I saw this issue posted.

1 Like

Perhaps Librem should take some lessons from NixOS ( - or ship it. When an update borks your NixOS system, you can always rollback. Great for reliability.