Keyboard and touchpad Qubes OS - Librem 14

I’m using Qubes OS on Librem 14.
The keyboard is not good at all. There are keys that should be pressed hard in order to be typed.
The touchpad is not good as well. There are times when it is laggy and I can’t use ‘tap to click’ [one finger or two fingers].

How can I add ‘tap to click’ functionality into Qubes and is it there a way to improve keyboard as well?
L.E.: are there some drivers for the screen as well as the color is pretty different than the asus rog used for work…

Are you using Qubes 4.0? Tap to click worked for me right out of install on 4.0. You should be able to enable it by going to System Tools -> Mouse and Touchpad, click the device dropdown to select the touchpad device, then click the Touchpad tab, then check the Tap touchpad to click setting.

Agreed regarding the keyboard and touchpad. Keyboard a key in particular sometimes doesn’t work, and the touchpad is really finicky when trying to click buttons such as the x to close windows. I’ve tried changing some of the settings such as acceleration but no matter what it feels so much worse than the experience of using a Macbook of any sort. I’ve been using a USB mouse for the most part because of this which feels much better.

I changed on Touchpad tab but the setting doesn’t remain enabled.
When I open again the settings that option is still disabled [unchecked]

I can do so on xfce but not on i3.
Any thoughts?

Create file 90-touchpad.conf to

Then edit it to be:

Section "InputClass"
        Identifier "touchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
1 Like