L11: USB tethering

When I connect my L5 with my laptop, on both ends showing um interfaces, usb0 in the L5 and en7 in the MacBook. See also USB tethering with a MacBook Pro

When I do the same with the L11, with the same USB-C cable, no interfaces are coming up. The messages in /var/log/syslog are:

2023-11-03T09:34:49.131639+00:00 pureos kernel: [ 4049.766672] usb 1-7: USB disconnect, device number 29
2023-11-03T09:34:49.248747+00:00 pureos acpid: input device has been disconnected, fd 16
2023-11-03T09:34:49.291865+00:00 pureos acpid: input device has been disconnected, fd 17
2023-11-03T09:34:49.348458+00:00 pureos acpid: input device has been disconnected, fd 18
2023-11-03T09:34:50.051901+00:00 pureos kernel: [ 4050.683120] usb 1-7: new full-speed USB device number 30 using xhci_hcd
2023-11-03T09:34:50.203616+00:00 pureos kernel: [ 4050.835719] usb 1-7: New USB device found, idVendor=1018, idProduct=1008, bcdDevice= 1.00
2023-11-03T09:34:50.203651+00:00 pureos kernel: [ 4050.835740] usb 1-7: New USB device strings: Mfr=0, Product=0, SerialNumber=0
2023-11-03T09:34:50.207621+00:00 pureos kernel: [ 4050.840763] input: HID 1018:1008 as /devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0/0003:1018:1008.0025/input/input75
2023-11-03T09:34:50.210309+00:00 pureos mtp-probe: checking bus 1, device 30: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-7"
2023-11-03T09:34:50.210646+00:00 pureos mtp-probe: bus: 1, device: 30 was not an MTP device
2023-11-03T09:34:50.267538+00:00 pureos kernel: [ 4050.901032] hid-generic 0003:1018:1008.0025: input,hidraw1: USB HID v1.11 Keyboard [HID 1018:1008] on usb-0000:00:14.0-7/input0
2023-11-03T09:34:50.271531+00:00 pureos kernel: [ 4050.906335] input: HID 1018:1008 System Control as /devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.1/0003:1018:1008.0026/input/input76
2023-11-03T09:34:50.331538+00:00 pureos kernel: [ 4050.963080] input: HID 1018:1008 Consumer Control as /devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.1/0003:1018:1008.0026/input/input77
2023-11-03T09:34:50.331560+00:00 pureos kernel: [ 4050.963251] hid-generic 0003:1018:1008.0026: input,hiddev0,hidraw2: USB HID v1.11 Device [HID 1018:1008] on usb-0000:00:14.0-7/input1
2023-11-03T09:34:50.363106+00:00 pureos mtp-probe: checking bus 1, device 30: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-7"
2023-11-03T09:34:50.363676+00:00 pureos mtp-probe: bus: 1, device: 30 was not an MTP device

What do I miss in the L11?

lsusb is your friend.

Was that the log from the Librem 5 or the Librem 11?

lsusb shows and does not change when the cable is pluged-in:

purism@pureos:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 026: ID 1018:1008  
Bus 001 Device 007: ID 0c45:636b Microdia Hy-HD-Camera
Bus 001 Device 005: ID 1bcf:28c4 Sunplus Innovation Technology Inc. HK 5M CAM
Bus 001 Device 003: ID 1a40:0801 Terminus Technology Inc. USB 2.0 Hub
Bus 001 Device 002: ID 05e3:0751 Genesys Logic, Inc. microSD Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The provided log was from the L11.

I think that rather anonymous device would be the Librem 11’s keyboard. Did you have the keyboard connected at the time??

You’ll notice that bus 1 device 30 gets recognised but does not show up in the output from lsusb and that the Librem 11 checks it to see whether it is an MTP device (such as would be useful if you plug in a mainstream phone or maybe a digital camera).

It looks as if some support for the Librem 5 is missing from the Librem 11 - which is not an ideal situation for Purism.

That said, many people would tether via WiFi, not via USB. Have you tried that tethering approach on the Librem 11?

PS You’ll notice that a Librem 5 that is not in serial download mode comes up in a “generic” vendor id. I don’t know whether that is a piece of the puzzle.

The keyboard was connected in that moment.

I do not know what you mean with tether via Wifi.

At home, when the L11 and my laptop are connected to my AP, I just use SSH to connect from the laptop to the L11 (or L5). In my company both can’t connect to the same AP, the L11 (or L5) must connect to the visitor AP and my laptop normally connects to our office AP, from where I can do SSH to all places, but not into the visitor Wifi network (and vice versa ofc also not). That’s why with the L5 I do use tethering via an USB-C cable and run SSH on top of this link.

Outside, for example in cafes, I use any mobile phone as an AP to Internet and connect the L5/L11 and my laptop to this AP. This allows also SSH between L5/L11 and the laptop.

I filed an issue here: USB tethering does not work at all (#44) · Issues · Librem 11 / librem11-base · GitLab

The basic idea is that you are out and about (so your home WiFi is not an option) and your phone has a mobile data connection but your other device (in this case the Librem 11) has no mobile capability at all … so you want to use tethering in order to get internet access on the other device.

There are three potential communications technologies to use for tethering

  • USB
  • WiFi
  • Bluetooth

WiFi is in some respects the most convenient (doesn’t require a cable) and should be adequately secure.

So the Librem 5 puts its WiFi card in Access Point mode (aka Hotspot mode) and the Librem 5 routes traffic from the WiFi interface to the mobile data interface - and all the Librem 11 has to do is associate with the WAP that the Librem 5 advertises. (I believe this option is on the GUI of the Librem 5.)

Bluetooth not further discussed here. I have no idea whether it works for tethering when using the Librem 5 and what would be involved. It’s comparatively slow anyway.

1 Like

I wouldn’t have called this “tethering over Wifi”, but just “using L5 as Access Point”, anyway.

But, this does not match my use case, which is

Internet <-- AP "visitor" <--Wifi-- L5 <--USB tethering-- MacBook --Wifi--> AP "office" --> company LAN/WAN/Internet

From the MacBook I run SSH into the L5 to read and answer there with the MUA mutt my (private) mails. This is the current config with the L5 and which I want to have with the L11 because of its bigger screen and the hardware keyboard.