L14: Bluetooth mouse occasional disconnect


Would anyone know what’s happening here or give me some pointers of which logs to check or services to restart?

I’m on a Librem 14 running Fedora Workstation 34 / Gnome 40 / swaywm.

I have a Logitech MX Master 3 (the “Mac” edition, which means it only connects over Bluetooth and didn’t come with the Logitech Receiver dongle).

I also have a Dell laptop running the same OS - no issues there.

The issue is that on the Librem 14 sometimes the mouse will just stop responding. I can’t move the cursor or click anything. When this happens the trackpad continues to work. I can also change the active device to the Dell laptop and the mouse continues to work there.

In order to get it working I need to flick the hardware switch for WiFi / BT on the Librem off, then on. Just for a second. Then the mouse starts responding again about 10 seconds later.

I’ve also tried other fixes like restarting the Bluetooth service, but that doesn’t have any effect.

Edit: I was also having some trouble getting PureOS Live USB to boot. After a few tries I was finally able to get the beta to boot and updated Librem-EC so I’ll see if that fixes it.

1 Like

Just replying to say that I wasn’t able to resolve this yet. I went about 24 hours without the issue occurring since updating Librem-EC, but it just happened again twice within about 10 minutes.

The same thing happens for me. I think I had to enable the buster nonfree repo and install the firmware from there to get Bluetooth working in the first place, but I am on PureOS.

I have exactly the same issue with a Librem 13v1 running Debian and a ThinkPad bluetooth mouse. The mouse works fine a couple of minutes, than suddenly it stops working. (The same mouse works perfectly with RedHat Linux on a Thinkpad T14). I use the latest coreboot version (upgraded on March 18th).

I run into the same issue on a Librem 14v1 with PureOS.

At this point I just have a line in my bash history that I reference with Ctrl+R ‘bt’:

sudo rmmod btusb; sleep 2; sudo modprobe btusb; sleep 1; sudo systemctl restart bluetooth

I use this to restart Bluetooth to connect with my Logitech M720. After 10 seconds or so, it works fine again. I think what’s happening is happening in the BT firmware, which is proprietary.

If there’s ever a side effect to this that I can figure out, I’ll have it hooked up to trigger a cron job and it won’t be a problem anymore…