L14 external speakers

Anything I need to do so the speaker/mic jack will recognize an external speaker on the L14? Or is that not possible yet? Internal speakers seem to work fine, but even in settings, it doesn’t see external speakers when plugged in, and obviously doesn’t switch over automatically.

I’m not running PureOS, but on Linux Mint I have to manually select the external hardware in Sound Preferences (…sometimes). Do you have something similar?

There is a drop down menu in preferences for sound output, but internal speakers is the only option that is there.

this was just fixed in firmware a few days ago. If you’re running the standard coreboot/SeaBIOS firmware, you can update now via Purism’s coreboot utility script. If you’re using Pureboot, the update will be released in the next few days.

After the update, the Sound output options will show an option for headphones/external speakers. Auto-switching on insertion isn’t working just yet.


Ok thanks, I’m still waiting on the update/upgrade to finish, so I’ll try it in a couple hours when that is done.

so after restarting I get this error message…

Detailed errors from the package manager follow:

Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached

Try to do sudo apt full-upgrade

1 Like

Thanks I will try that now.

After many lines of “Setting up …” then 3 lines of Installing new version of config files, I get this at the bottom.

fwupd-offline-update.service is a disabled or a static unit not running, not sta
rting it.
fwupd-refresh.service is a disabled or a static unit not running, not starting i
fwupd.service is a disabled or a static unit not running, not starting it.
/var/lib/dpkg/info/fwupd.postinst: 54: dpkg-vendor: not found
Setting up libavcodec-extra58:amd64 (7:4.3.2-0+deb11u2) …
Setting up libavformat58:amd64 (7:4.3.2-0+deb11u2) …
Setting up libavfilter7:amd64 (7:4.3.2-0+deb11u2) …
Setting up fwupd-amd64-signed (1.5.3+2) …
/var/lib/dpkg/info/fwupd-amd64-signed.postinst: 17: dpkg-vendor: not found
Setting up libavcodec-extra:amd64 (7:4.3.2-0+deb11u2) …
Processing triggers for libc-bin (2.31-12) …
Processing triggers for man-db (2.9.4-2) …
Processing triggers for dbus (1.12.20-2) …
Processing triggers for hicolor-icon-theme (0.17-2) …

Try fwupdmgr get-devices or with sudo. Does it give errors after restart?

Nope. Maybe I will run the script @MrChromebox suggested earlier again when I get a chance.

Purism doesn’t use fwupd for firmware updates at this time

This error was caused by a bug in earlier version of fwupd and doesn’t have anything to do with firmware update script provided by Purism.

Should I use the same script to install LibreWolf again?

As it states that is only for Debian unstable (not for any of its branch which are even based on it). My mistake on that part, should have checked which script you were using.
Maybe just grab an AppImage from here.

1 Like

I missed that too. Newbie, duh! So I’m trying a flatpak now.

Ok, ran the script again after more OS updates and it all works now just as advertised. Thanks you again for your assistance @MrChromebox :+1:

And I’m happy to say I did it all without really having much of a clue as to what, exactly, was happening :rofl:


Does this also work for microphone input? Would love to use a better microphone for conferencing instead of the built-in one.

the external microphone input isn’t working yet unfortunately, although it is now selectable

Thanks for the info! Not sure if you can answer, but I’ll ask just in case:

Is this a technically complicated thing to get fully working / some unexpected challenges? Or just a matter of lack of resources/different priorities right now to address it?