L14 - Updated BIOS, now black screen

Updated my BIOS to pureboot-librem_14-Release-29.zip. After update the screen is now black… Ideas…

1 Like

That’s unfortunate given that you are selling it.

Do you mean that after a successful update, you rebooted and all you get is a black screen?

Can you outline what procedure you followed to update Pureboot?

@jonathon.hall ?

1 Like

I have two, my main is the one I was updating.

I came back to the machine and it was still on with a black screen. Waited there for awhile… It still doesnt show anything on screen.

Followed the steps here: PureBoot Getting Started Guide - Purism - Librem products documentation

Is where I got the BIOS: librem_14 · master · firmware / releases · GitLab

1 Like

So during the update? In other words, the update never completed as far as you can tell by looking at the screen?

Can you confirm more precisely how long you have waited?

1 Like

Yes during the update. Got coffee and came back to a black screen. I would’ve assumed during the update process it would’ve restarted or I would’ve gotten a prompt.


1 Like

I would make sure that you are on mains power, leave it as it is, and wait for Jonathon to respond.


Can do, I can wait as long as needed.


That,s normal s0me t1me need to go for SS Serial plus Shikra to recovery.

1 Like

Ya… nothing…
looks like a dead L14…


Sorry to hear that this problem occurred @Muadi. This is recoverable, but it might require a hardware flash.

You’ve waited long enough at this point, so force the system off (hold the power button) and try to boot again. Wait at least 2 minutes if it comes up to a black screen, it may be performing memory training. If it comes on, that’s great, we can check whether it updated or is still on the same firmware. If it doesn’t come up, then you will need to hardware flash.

  • This guide explains how to hardware flash a Librem 14 BIOS: How to Hardware Flash your Librem 14 Boot Firmware – Purism
  • The guide uses a Librem 5 to do it, but you can also use another laptop, or really any Linux device with a USB port.
  • ch341a programmers with the SOIC-8 clip are easy to find, e.g. ch341a programmer for sale | eBay has many listings for $10-15. You can also use other hardware like an FTDI USB device, Raspberry Pi, etc., but you still need an SOIC-8 clip or some way to connect to the chip.

Could you clarify what precisely led to this state? I would like to address the failure if we can identify it to prevent it from happening again in the future. For example:

  1. Were you updating from a prior PureBoot release? Do you know what release it was?
  2. After selecting “Flash, retain settings”, did you select a ROM from your flash drive? Do you recall the following prompt saying it was ready to flash, or the progress bar?
  3. Did it finish flashing and present the final prompt saying it was ready to reboot? Do you remember pressing Enter there?

Whatever details you recall would help me determine where exactly it failed, I’d appreciate anything you can provide.

1 Like

I was on release 28… just the one prior. EC was running on current version as well.

I loaded the release 29 bios onto the the USB device, following: How to Hardware Flash your Librem 14 Boot Firmware – Purism setups to ensure I did things correctly. Unfortunately I only recall seeing the start of the update taking place and thats when I walk away from my workstation. I know that it was working through the BIOS flash with no errors.

No, when I came back to my computer the screen was black so i dont know if there was a prompt or not. It stayed black for several hours. After working with support and with the help of the form i tried unplugging the CMOS battery for 15mins and then plugged it back in… nothing.

1 Like

Thanks for the context, it’s helpful as I look through to try to track this down. (BTW that was a mis-pasted link right, you were not trying to hardware flash the first time?) The AC adapter was plugged in, right?

The only other thing you could try at this point is swapping the memory modules - if you have two, move each DIMM to the opposite slot, if only one then just move it. This forces it to refresh the SPD caches and re-do memory training, it’s probably unlikely to make a difference but it has worked once or twice.

Other than that it sounds like it will need a hardware flash.

1 Like

haha yes no… not that… was a just a BIOS flash the normal way… not hardware.

Good idea! ill try that when i get a chance… change things up for the system to see if i get any response.

Yea if its a hardware flash, so be it… not a big deal.

1 Like