L1UM Boot Issue with XCP-ng


I have a L1UM and am having difficulty booting any OS other than PureOS / Debian. In this case I would like to install XCP-ng (xcp-ng-8.2.1.iso), but no matter which boot option I select it always hangs at “Starting the new kernel”. Same is true when I tried to manually boot with kexec. I have also tried turning off IOMMU as recommended by XCP-ng for troubleshooting boot with either the intel_iommu=off or iommu=0 kexec flags, but with the same result of hanging at starting the kernel. Image is with the “multipath install” boot option selected in the XCP-ng boot menu, but the same thing happens with any of the options. Any advice is greatly appreciated.

This is probably because PureBoot does not provide a framebuffer to the target kernel. It is booting, but there’s no video output. This also happens for memtest86+ and Debian netinstaller.

You might be able to do the installation over serial. I haven’t tried XCP-ng myself, but since there’s a “no-serial” boot option I’m assuming it enables serial for the default. Unattended installation might also be an option. The physical serial port is the COM1 header on the board, I believe all L1UM v1s had that. USB-serial might also be an option.

We recently fixed this for Intel graphics upstream in Heads (will be in the next PureBoot release), but Aspeed will require another strategy, which also trickles down into improvements needed in fbwhiptail, etc. There is some work on it in Heads but it is incomplete.

Thank you very much for the info and suggestion! I have a serial cable on the way, I’ll update when I get a chance to try it.