L5 call audio quality

Given that there was a recent review on German golem.de which complained about the audio quality of calls, I was very curious about it. I have an L5 Evergreen with byzantium flashed onto it.

The easy part first: Incoming sound quality was pretty good right away from the start. No need to tweak anything.

The harder part: Outgoing sound quality. My wife complained I would sound quiet and “somehow muffled” with noise in the background (despite being in a quiet environment). The volume sliders in the graphical settings app seemed turned up, so more fiddling was in order. But I was quite scared to turn the wrong knob and turn the wrong volume up/down, ending up with a dsyfunctional phone of my own doing. (There are quite many of these knobs!)

So the package alsa-utils to the rescue, it contains alsamixer, and alsactl which I needed. First, thanks to a suggestion by Guido Günther, I stored all my values in a file, so I could restore them later to the original ones in case I screwed up. The commands to save all values to a plain text file and to later restore them if needed are:

alsactl store -f alsa.conf 
alsactl restore -f alsa.conf

OK, being on the safe side, I turned to alsamixer which provides a nice interface on the console.

Protip, doing this through ssh from a real computer lets you a) nicely use the keys to navigate, b) provides a large enough screen to see stuff and c) lets you make test calls WHILE you remotely turn up/down the volume on the L5

In the end it turned out that I needed to:

F6 (select soundcard) -> choose "0 Librem 5" (I could have started it with alsamixer -c 0 for the same effect)
F4 (show only Capture devices)
Navigate to "Digital" (the 9th column from the left) which was quite low and boost it up to 100%.

My wife understands me much better now! :heart:


How do you do that, can you choose byzantium already when flashing, or you flash the default way first and upgrade to byzantium afterwards?

This is worth every trouble with the command line! :wink:



 ./scripts/librem5-flash-image --dist byzantium

L5 developers @dos already fixed the issue “sound quiet and “somehow muffled” with noise in the background” on amber as far i know.

PulseAudio version in Byzantium doesn’t contain the patch needed to adjust the parameters of the echo-cancel module yet, so it’s expected: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/400


Did you say “Can you hear me now?”

Don’t you mean she HEARS you much better? Understanding is something completely different…lol

Of course you can’t understand a person well if you can hear them well, so it seems logical to me.

I think the internet/sarcasm filter is on…lol. I was attempting to make a joke.


Obviously he is not married…

1 Like

The classical way to test calling quality is: “Das Pferd frisst keinen Gurkensalat.”

1 Like

Or ZPF1 to 5

I am really at a loss with the call audio quality. People complain about poor sound from my side most of the time, sometimes it the person at the other end can’t make out what I am saying at all. Complaints vary between “you sound very distant”, “you sound muffled or like you are sitting in a box”, “are you on a construction site?”, “your mic seems to pick up every background noise” etc. etc.

The problems appear both with and without the Librem5 headphones and I just can’t seem to find any mic setting that works consistently and reliably. I tried the alsamixer suggestion in this thread, but no consistent improvement.

Shouldn’t there be a default mic setting that just works? As it is now, I am constantly experimenting with different input levels of the mic, but can’t find what produces an acceptable outgoing call audio quality.

I have heard similar complaints from people I talked to on my Librem 5.

What is needed I think is some systematic testing, which I have not had time to do yet. One idea is to use a voicemail service that can record the sound from calls, then call that and play a specific sound into the mic using some other phone and then do the same thing using the Librem 5, then compare those two recordings. Find a case where the Librem 5 performs poorly compared to other phones and then investigate that case further. I will try something like this if/when I have time, unless someone has better ideas.

1 Like

It sounds like it’s “every case.”

I’m pretty sure there are some cases that are worse than others. In particular regarding background noise, I suspect that the Librem 5 does not manage to remove background noise as successfully as many proprietary software driven phones.

Note that using the headphones still uses the internal mic as far as I know. As the phone doesn’t yet support the headset mic yet.

So, selecting the “Headset Microphone - built in audio” with headphones connected effectively mutes the phone then? And does that mean I have to leave at “Internal microphone” to be able to talk to someone?

Here’s what I see in the sound settings with a phone received just this week:

  • plug in a headset and the output automatically switches to “Headphones” – which work
  • at the point the input still shows “Internal Microphone” – which works according to its meter
  • but now you have the option to select “Headset Microphone” – which does not work.

Tried both the headset shipped with the phone and my old one which is in daily use.

Sounds like someone know that “Headset Microphone” is a mute setting, and avoided automatic switching to have at least some microphone, though not the one you think you are using.

Might add: I switched the SIM back to my old phone because the other end couldn’t hear / understand me well … now I know why.