L5 My Hoyoki arrived, to run phone through desktop?

Reading other posts, I bought the Hyoki USB-C Hub.
I have the Evergreen w/ L5 updates.

I also have a Z400 Workstation running Pure OS as well.
The workstation does not have any USB-C so I have a USB-C/F to USB-A/M adapter for the Hub that will connect the male USB-A to workstation.
I think from what I read, that next I will connect the L5 to the HUB using the USB-A or USB-C port on the HUB?

The plan is to connect the L5 to the HUB and hopefully, similarly do what the Puri Lapdock does. i.e. Let me connect a wireless keyboard/mouse combo to the HUB USB-A receiver

Do you think I’m doing it right :+1:, or :-1: ?

Just sign me ‘anxious’.


I don’t think you are doing it right. That said, I may have gotten the wrong end of the stick of what you are trying to achieve.

With the Librem 5 and that hub …

  • connect the Librem 5’s original power supply to the USB-C socket on the hub
  • connect any keyboard and/or mouse using any USB-A port(s) on the hub
  • connect the hub to a monitor (or TV) using an HDMI cable
  • connect the hub to the Librem 5 by using the integrated USB-C cable of the hub

The Z400 doesn’t really come into it.

I had everything off, and followed your directions perfectly. It’s probably a glitch in the Matrix. HDMI to Hub doesn’t get recognized. Nothing shows up, L5 isn’t showing up on monitor but when holding the L5 and tapping on keyboard, I can feel the slight buzz so keyboard is seen, but not on monitor.
Is there software or commands needed in L5 maybe?

The power on the L5 went from 97 to 87 in 45 minutes so it’s not charging on that setup.


If docked mode is recognised automatically (which it should be) then no commands should be needed.

For the monitor, check Settings / Display (under Devices?) to see whether two monitors are showing up? The normal monitor is the built-in display of the Librem 5 and the extra monitor that should show up is the external monitor. (Even if the external monitor is not working, if you open a terminal on the Librem 5 and type on the keyboard that is attached to the dock then your typing should show up in the terminal.)

Is this a Logitech Unifying Receiver for the wireless keyboard / mouse combo? I’ve had good success with Logitech wireless keyboards connecting to Linux via the little receiver dongle thingy (but I don’t think I’ve ever tested keyboard / mouse combo, and I can’t swear that I have tested with the Librem 5, because I am mostly using Bluetooth keyboards with the Librem 5, and because my Logitech keyboards have a built-in trackpad, which is good enough to get by with most of the time).

In any case
is your starting point to see what USB peripherals have showed up on the Librem 5. (You might have to type this command on the on-screen keyboard of the Librem 5 as the external keyboard apparently isn’t recognised yet.)

cat /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent

to see what has been negotiated for power. Post output. (You will almost certainly want to get the keyboard sorted out before entering the above command. :wink:)

Disclaimer: I don’t own the hub that you have bought but seeing as Purism sells them I guess Purism should provide some basic documentation for initial setup.

I’ve been having the same issue with the monitor not being recognized.
Tried with the “official” dock and another. They work when connected to another host so it’s definitely an L5 issue.

1 Like

Right after turning monitor on, then everything else that I had connected to Hub, and get “Check Signal Cable” on the external monitor, L5 dekstop looks as usual.
I tuned everything of, and plugged monitor dongle back into tower, and it and keyboard work.

I also tried it on a regular desktop - same results - nothing.

I did the “lsusb” and made a screencap, but it’s a :disappointed: obstacle course to get it off the L5, and onto the tower and from there into the network, then onto this tower, and then add it into a reply here. I just love how technology has made things simpler. I’ll do it late - I’m too ready to use it as target practice.

What make and model? I guess there’s an outside chance that I or someone else will have the same monitor to test.

Let me make it easier then.

Do lsusb on the Librem 5 before you plug the dock into the Librem 5. Then plug the dock into the Librem 5. Then do lsusb again. Note down what changed.

Only report here things that newly appeared in the output from the second run of lsusb i.e. ignore anything that was already there. Just type in to the forum the USB ids and the description after the USB id (being careful to transcribe the USB ids correctly).

Also, that information should be partly the same when the keyboard and mouse are visible on the tower. So, where the information is the same, you can cheat and copy the information from the output of lsusb on the tower. NB: The Bus number and Device number will very likely not be the same between tower and Librem 5 but I am not interested in the Bus number and Device number.

Even if you can’t report any output at all, it should be relatively obvious whether a keyboard / mouse appear, or whether anything at all appears. ???

You didn’t answer my question about the make of keyboard / mouse combo but here’s what one looks like for me on a desktop computer.

Bus XXX Device XXX: ID 046d:c52b Logitech, Inc. Unifying Receiver

Samsung SyncMaster S27B370
Both VGA and HDMI
Unfortunately, Samsung doesn’t support it’s monitors like they use to. The best Spec I have is at Manuals.ca There is probably a manuals dot everywhere else too.
As for the “lsusb” I’ll do now. Hope the monitor info above is useful.
Doing the mini-obstacle now :smirk:


EDIT: Btw, the monitor displays the VGH, (tower) connection direct from tower to monitor. so I disconnected that and rebooted everything with just HDMI - still nothing.

Unfortunately no Samsung monitors or TVs here. Maybe someone else at least has a Samsung monitor in that range to test with the Librem 5.

Bear in mind that monitors have various behaviours regarding how they handle multiple video inputs. So you definitely did the right thing by disconnecting the VGA input (in case the monitor uses VGA in preference to HDMI if both are connected). Some monitors will automatically select the input if exactly one input is connected. Some monitors might require you to choose the input manually which you would do using the On Screen Display (OSD) and buttons (usually at bottom right) on monitor.

Does the tower support HDMI output? If so, it would be better just to use HDMI exclusively and that way confirm that HDMI from tower to monitor (including HDMI cable) is working.

Well my browser is telling me that manuals.ca is hosted in France anyway.

For my country it is telling me that “This domain may be for sale” so apparently not everywhere. I declined the suggestion of buying the domain. :wink:

@irvinewade What monitor do I need to use for the device so I can use the recommended dock/er for the L5 Evergreen assumed not made in USA?

Maybe if I buy a card with HDMI. But, what has the tower to do with it?
The tests were done w/ then /w tower.

Both.Wireless Blackweb mouse/keyboard.

Test results coming in about 1 hour.

Let’s take that as a “no” then.

As such, nothing - but it’s fault isolation. At this stage HDMI is not working but you don’t know what part of it is causing the problem.

Looking on the web, that has a nano receiver. Just plugging that into the tower and posting the line of output from lsusb from the tower that pertains to the nano receiver would be helpful.

In principle, if you have a USB-C male to USB-A female adapter (small and cheap), you could plug the nano receiver directly into the Librem 5 and determine whether that arrangement works. That could eliminate the dock from the puzzle.


Sorry, had to do it the hard way.

lsusb without hub


lsusb with hub


and the cat


In case I forgot, I tried it with cabled keyboard/mouse and a 8" HDMI monitor. Still nothing.
I rechecked the suggested connections and their order (above).

I thought of the Lapdock but 2 things - (1) it’s about $700.00 to me and (2) scared it won’t work either. This, from all accounts, should work. Hug, L5, cable,

Is that a light or a train? :slight_smile:

OK, so that output shows that a Video Adaptor has appeared (good) but no keyboard and mouse has appeared (bad).

Have you gone into Settings to see whether a second monitor has appeared?

Shows no recognition of charging at all.

I’ll have to wait till I can get a ride in to town. Digital devices - :poop:

What is bad? wireless kboard/mouse, wired kboard/mouse, HUB,

L5 > Settings > Devices > Night/Day for One device. Nothing else there.

Frankly, I don’t have much faith in either the devices any more , the hub or cables anything between.
I will also try it on a ASUS, Toshiba, Dell laptops. I can also try in on more monitors, but need to take down our network for that so it will have to wait until April 29 when we do maintenance.

I don’t know what other tests I can do to prove it’s not the “phone” at fault.

Got this in Jan 25. Only thing it can do is really P me O.


It is bad that no keyboard or mouse appeared even though you had one plugged in to the dock.

I don’t remember if I sent the stats for the cabled in. I know nothing worked, but didn’t lsusb today and let you know. You are my only hope - no pressure :slight_smile:

Have you tried plugging in the monitor last (i.e. after the phone is plugged into the hub).
Probably wont matter, but I think it makes a difference for my Samsung tv.

1 Like

In that case you might consider also getting a standalone USB-C to HDMI converter as well, while you are there.

I am mindful that you have already sunk plenty of dollars into this and without getting much joy - so the two suggestions (USB-C M to USB-A F adapter; USB-C to HDMI converter) are intentionally relatively cheap items that can fault isolate.

Did you buy the hub from Purism?

It’s a wonderfully super great idea. But I have tried it already :slight_smile: Makes two of us.
Also tried it with k/board/mouse wifi, and wired, and with another monitor.
I think that as of now, the only thing I didn’t try requires a gun - which I don’t have.

No. :flushed: When I keyed it to a search engine, Amazon had it @ almost half the price - what can I say. They are sending me another one, provide I return the other. That’ll be about 3 -4 weeks. I need it last month :slight_smile: