L5 My Hoyoki arrived, to run phone through desktop?

You’re confident that the device that Amazon sells is actually the same device?

But, yeah, if you are going to buy something from Amazon then I guess you can’t ask Purism for support for the device you bought.

[quote=“irvinewade, post:21, topic:19718”]
You’re confident that the device that Amazon sells is actually the same device?[/quote]

Yes. Same.

I didn’t feel great about it. But I don’t feel guilty. On the other hand, I paid a total of $59.21 (CAD) including shipping and handling. I think Amazon uses their own trucks, and my last experience was with DHL and it was a bad one.
With Puri, It would cost me CAD $67. just for the product plus add shipping, taxes, and duty.
Sometimes I can be very charitable, but for this, I had to do what I had to do.

Building a loyal following needs to offer something in return. Gotta admit, there are a great bunch of folk manning the Help Me arena here, and more help just searching the posts.

Hoyoki is a great tool and I’d love for it to work so I can use the The LapDock looks good… but, I don’t like the cost, about $546. plus shipping, and taxes to me, and what if it doesn’t help and it turns out it is the L5! Yoiks!

If I get the Ltop setup with PureOs and test it to the Ltop screen and mouse. I think you mentioned that the monitor (Samsung) wasn’t detected. Using the Ltop might probably point towards issue not faulting L5. If not monitor or L5 , then? Do you know any exorcists .:slight_smile: ?
I see one probable immediate issue with that - will L5 charge. But I’m going to try anyway.

Just a FYI, I have the dock from amazon too. It works perfectly with my new Librem5.

1 Like

Perhaps you would be good enough to review the post above: L5 My Hoyoki arrived, to run phone through desktop?

In particular, I’ve given an unordered list not an ordered list i.e. I don’t know whether the order in which you make the connections is relevant.

And if you wanted to be super nice, you could post a photo of your setup.

1 Like

Thanks @lo0. Can you tell me how your set is? i.e. Is your monitor HDMI, Wifi keyboard & mouse? I’d appreciate it. With the great help from others’ here, we’re trying to narrow down, to which is the culprit; L5, Hub, cables, monitor/keyboard or mouse. Oh, and me, of course, can also be the culprit.


Yeah so in my setup I have the Hoyoki dock. Connected to the dock is a 32inch 1440p monitor via hdmi, 1g ethernet via the rj45 port, a librem key, another usb 2.0 hub that has my logitech trackball and microsoft keyboard attached to it, and the included librem 5 usb-c power cord. The last thing I plug in is the librem 5. I switch this dock between the librem 5 and my librem 14, works great with both.

1 Like

Well, anyone with a similar problem may find it useful. Unfortunately, I have done everything, in essence to prove it’s not the L5. I don’t know what else to do since the L5 couldn’t have anything wrong with it.
I have tried all new cables, except for one, and I might be able to get it this weekend. If it’s not that cable, and not anything else, then it must be the type of current I’m using, or maybe the way it’s facing, … :face_with_symbols_over_mouth:

Thanks for your help, I do appreciate it.

As suggested:
I bought a Bluetooth set up.
I borrowed a good HDMI monitor.
I used cabled, mouse - then wifi mouse
I used cabled keyboard then wifi then both, then combo wifi Mouse, cabled keyboard then reverse combo then bluetooth set up, then combo.
I used all new cables
I prayed, cussed, cried, threatened, shook my finger at it, & bribed the L5
I may have left a finger-path on the screen from all the boots, reboots …

Psychotic key taps and swipes.
Top left [<] back button needs 6 -10 taps, and the icon greys on-tap, to wake it the up!
1 - 6 swipes to swipe.

Most programs run off the side of the screen. I know, I can set each one individually - not funny.
Camera settings don’t stick. have to set everything on high/max if inside, forget outside - too bright. It’s 2023 and I doubt anyone with a “Cell phone”, “smart phone”, Evergreen has to ask everyone to hold the pose while one fiddles with the camera setting testing until best lighting works. I KNOW - some techs phone works sort of. Swap?

The blessed thing that can vaguely be thought of as progress, is that the L5 device charges now from the Hoyoki & local tech shop is richer.

Everything points to the impossibility that it is a faulty device.

When you have eliminated the impossible, whatever remains, however improbable, must be the truth. – Sir Arthur Conan Doyle

Whatever improbable is, it’s probably the improbable device itself. But, I’m told that is impossible.



I’m going to assume there is no “NEXT”!

But for other poor a souls wandering the halls of possible answers, I’ll mention how I’ve followed up on some suggestions.

This is the 29th post on this topic and went silent 7 days ago when I asked “NEXT?”

I figured it is either the HUB or the L5. To test this, I ordered a replacement for the HUB. Some say, it is not the L5. Kewl, without even testing it! I don’t trust long-distant crystal balls, so I’m going to test it with the new HUB. Same make, model that is same no matter what store shelves they sit on. (Puri sells the exact same Hoyoki hub)

After following @irvinewade suggestion (Post #2 above) I plugged everything in-order as suggested.

The new hub reacted exactly the same as the other one. The only noticeable difference is the amount of time wasted.

THIS L5 cannot recognize the HUB,. It’s that simple. TWO identical hubs respond the same way. One cop-out might be that I save about $20 buying it at Amazon. Got here in 4 days, no hold-ups on the way. No 3rd, 4th, or 5th parties carving out their retirement funding.

Since it’s taken a long time to sort out the issue with the hardware that handles taps and swipes, reaction is all over the map, and the return policy prohibits me from exchanging or refunding L5. NOTE: support@puri.sm did offer to help.
I have handed the L5 to a few different people and asked them to enter the pass numbers open a browser, and go to grc.com and test w/using Shields Up. They give up. Next, open the editor and type in “Your dog has fleas.” Fumble, fumble, and it would get handed back with descriptions of the L5 that I won’t post.

There, I have it. Tested on TWO identical hubs with same result. Can slow-charge the L5 with the Hub. That’s it. Using the Tap/Swipe is the most frustrating thing. Tap/Swipe is as close to insanity as one can get.

This is what the device has that sort of works.

  1. If plugged directly into the charge, charges fast.

  2. It made and received a call when testing the phone. Spam works too.

  3. The game 2048 works.

Hopefully, Support, the other support, not this support, will respond soon with help. From what I’ve read, I’m not holding my breath, not waiting around and suggest you don’t either. Not everyone has this problem with their L5, I seem to be the lucky one. So, don’t make a decision based on my experience, but should do what I wasn’t aware of:

  • Note the date and time you received the L5.

  • Follow the set up. Get the updates, upgrades, patches, fixes.

  • Test EVERYTHING. Test in portrait, landscape, light room, dark room.

  • Test camera. WARNING, do not expect camera to be anywhere near what cell phones have. It’s a work in progress (a/o Apr. 03.2023).

  • Test modem, mobile, and if you think you might need, or have Bluetooth, test it Now - before your 30 days leave you with a brick or expensive repair jobs.

  • If you are experiencing great difficulties when tapping and/or swiping, have a friend video the issue, - you’ll need proof.

Good luck

Sorry you are experiencing so much trouble with yours :frowning: For what its worth, mine did not recognize the display connected to the hub the other day. I was in the middle of something and the L5 is not my daily yet so I didn’t bother to troubleshoot it at the time. Went to use it again a few days later and after charging it back up it was working normal again. Not sure what happened

Did you try to update the firmware?

The only thing I understand is:

I have not tried that (maybe) yet because some say do it, others say not to. But to use it as it is, is just too frustrating & time consuming.
What in your, estimation, would happen if flashing fails?

I’ll have to try the check using the sudo thing. But, with the psycho tap, it will be a most interesting adventure. Raising child would be easier - even in there demented times :grin:
Thanks for chiming in.

Seriously, you need to get this fixed. It must surely be impeding trying to do anything else.

As far as the firmware on the USB-C controller goes, I would suggest checking the firmware version. Given that your phone is quite recent, my guess is that the firmware is up to date already.

The incantation for checking the USB-C port controller firmware version is:

sudo cat /sys/kernel/debug/tps6598x/0-003f/customer_use

Please do that and post the output here.

This has nothing to do with flashing the main software though (which is what I suggested might be required by Purism support).

As far as the main software goes, of course you could render your phone unbootable in the normal manner if it fails badly but the good news is that you can have as many attempts as you like, both initially and after it fails (if it fails).

Don’t I wish!!!
It was, without dropping the F bomb, very interesting tapping all that in. I am not able to copy & paste from the desktop that can use. So I type the result back here.
Reading the tiny print:

purism@l5:-$ sudo cat /sys/kernel/debug/tps6598x/0-003f/customer_use
I dbl checked the number 99% sure they are correct.

OK, all good. You are up to date on this one. We can expunge all talk of updating the USB-C port controller firmware.

Whew. That’s a relief - what ever that means, but it sounds good.

So you know, the L5 won’t recognize L5 USB-C into hub. When I use and adapt the L5 so it’s USB-A into USB-C male > USB-A female port on Hub, causes a tick-tock sound from L5 pushing it in, and same beeps when pulling it out.

No reaction from L5 pushing in/out any Bluetooth dongles, nor with the HDMI in/out.

Appears only the L5 recognizes the hub. Nothing else.

That’s not how it is supposed to be done though.
(Edit to fix confusing typo.)

For the hub to work fully, the Librem 5 must be plugged in to a USB-C port on the hub - and I believe the correct USB-C port on the hub is the one that is the “tail” of the hub (integrated USB-C cable of the hub). But I admit that I don’t own such a hub.

I think you meant noT not noW :slight_smile:

Yes, the tail goes into the C port on the pwr adapter, but with hub, L5 other end of Tail goes into C on Hub, and Hub plugs into C on pwr adapter.and the Hub plugs into the C, but nothing happens. No knock-knock.
Plug it into the C-port using the adapter (C to A), and when plugging it in, I hear the L5 do the knock-knock sound.
The same sound is heard when unplugging. Plus, it repeats the sound when testing each A port.(3) Nothing when plugging L5 into C port.
Checking Mobile Settings, > Convergence > “No known docks detected.” Even though the L5 knock-knocks,

That’s w/ the second Hoyoki BTW.

Technology reminds me of the joke “Many years ago my teacher told me not to worry about spelling because in the future there will be autocorrect and for that I am eternally grapefruit.”

I don’t think so but either you or @lo0 needs to post pictures of really what is / should be connected to what.

Or take a look at all the pix here: https://www.amazon.com.au/Ethernet-Charger-Multiport-Adapter-Chromebook/dp/B097R5LL7P (Is that the right ASIN i.e. what you bought?) Is that how you have it set up?

Yes. Oops.

OK then. Where is the hub to get it’s pwr supply from?

OK. There are 17 pics when I viewed the page. All but one is for different items Amazon is pushing.

(ASIN) Amazon Standard Identification Number is a ten-digit alphanumeric code that identifies products on Amazon.
Yes. That is the one. Don’t know it that’s their number or not, Just how many 8 port models like Hoyoki are there? Answer 1.

Still looking for other reasons? I think it’s high time Puri stepped up the plate and tale responsibility maybe Puri wants to take down their ad for the Hoyoki. Amazon did, right after I got them. One was shipped back this morning.

What is the Model number of the Hoyoki Puri is selling? You tell yours, and I’ll tell you mine.

There is no reason why I have fight with that piece of work to take a picture of anything. I know what I see, I know what it said , I know others here use them, I know this L55 is a piece of. How many times and how many new Hoyoki do I need to test this metal Kruger before we point the finger?
Too bad, the company went out of business, and I bought the last 2. Lucky &^^%$# me!
There will be one left, since I sent the other one back.

OK, I take it that after almost 90 :face_with_symbols_over_mouth: days, it’s still piece of :poop: can’t use the phone for anything. It’s a nightmare, and demon in disguised. I’ve way beyond cooperating, buying parts, and paying for mobile use that I can’t uzse.
I’m not asking for anything like refund, exchange or repair because others with L5 did, and trusted Puri to cough up the refund. Didn’t and some are still,waiting.

But, I know, when a company is pushed into the corner they come out deleting and screaming so far be it from me to let Puri say I wouldn’t cooperate so wait - and I’ll send you more pictures of what the L5 can’t work with.

Have a NICE ^&%%$^&* day Puri.