L5 todays update-no more calls

After todays update I am not able to make or receive any calls.

When I try to call it tries to connect but then it hangs up.

I I try to call L5 with another phone it appears to be busy.

It also frequently shows only 2G and not 4G as it used to show. And the 2G has typically the exclamation mark.

This is kind of urgent. I need to use the phone. Anyone else experiencing the same issues?

If not I need to downgrade. But how to do it. I do not remember what it installed today. Running ls -ltr in the package folder it seems that probably it installed these:

-rw-r--r-- 1 root root   17M May 20 03:05 linux-image-6.2.0-1-librem5_6.2.13pureos2_arm64.deb
-rw-r--r-- 1 root root  1.3M May 20 03:05 linux-libc-dev_6.2.13pureos2_arm64.deb
-rw-r--r-- 1 root root   29K May 20 03:05 linux-image-librem5_6.2.13pureos2_arm64.deb
-rw-r--r-- 1 root root  166K May 20 11:49 libkpathsea6_2020.20200327.54578-7+deb11u1_arm64.deb
-rw-r--r-- 1 root root   79K May 20 11:49 libsynctex2_2020.20200327.54578-7+deb11u1_arm64.deb
-rw-r--r-- 1 root root   73K May 21 17:49 libfontembed1_1.28.7-1+deb11u2_arm64.deb
-rw-r--r-- 1 root root  134K May 21 17:49 libcupsfilters1_1.28.7-1+deb11u2_arm64.deb
-rw-r--r-- 1 root root  198K May 21 17:49 cups-filters-core-drivers_1.28.7-1+deb11u2_arm64.deb
-rw-r--r-- 1 root root  561K May 21 17:49 cups-filters_1.28.7-1+deb11u2_arm64.deb
-rw-r--r-- 1 root root  152K May 21 17:49 cups-browsed_1.28.7-1+deb11u2_arm64.deb
-rw-r--r-- 1 root root   95K May 21 23:49 libwebpmux3_0.6.1-2.1+deb11u1_arm64.deb
-rw-r--r-- 1 root root   86K May 21 23:49 libwebpdemux2_0.6.1-2.1+deb11u1_arm64.deb
-rw-r--r-- 1 root root  238K May 21 23:49 libwebp6_0.6.1-2.1+deb11u1_arm64.deb

What can I do?

Have you tried rebooting the phone again? I’ve noticed that rarely the modem can get in a strange state where it doesn’t seem to work for anything despite showing as ok.


BTW, have you tried doing a restore from the Backups app? (I’m actually not sure if that reverts package versions, though. Anyone…?)

Those sound like seperate issues (I can’t reproduce either with the latest updates installed).
The poster appears to be experiencing an inability to make calls at all, and your calls seems to have no sound.

You likely checked, but I need to ask @guru, is your mic switch in the on position? I see volume on mine with the “Handset Microphone”.

I’ve seen what the op describes after several suspend/resume cycles when playing with the experimental suspend feature, which a reboot resolves. Could be something different though.

Thanks! I am an idiot, all is fine. I dialed our voice system and replayed the recording.

Can the calls app detect that the mic HKS is in off? If so, a warning for stupids like me would be good.

1 Like

Rebooted several times. No help.
All HKS switches are on.
I have never used the backup application. Maybe I should start doing this if it can revert packages.

Maybe it is better to see if a developer knows something about this case. If not, tomorrow I will try to revert the packages to the previous versions.

Thanks @amarok for reminding me the dpkg.log file. I will check that too.

1 Like

a grep 2023-05-23 dpkg.log | grep upgrade
gave me this:

2023-05-23 10:44:03 upgrade libcupsfilters1:arm64 1.28.7-1+deb11u1 1.28.7-1+deb11u2
2023-05-23 10:44:03 upgrade cups-browsed:arm64 1.28.7-1+deb11u1 1.28.7-1+deb11u2
2023-05-23 10:44:04 upgrade cups-filters-core-drivers:arm64 1.28.7-1+deb11u1 1.28.7-1+deb11u2
2023-05-23 10:44:04 upgrade libfontembed1:arm64 1.28.7-1+deb11u1 1.28.7-1+deb11u2
2023-05-23 10:44:04 upgrade cups-filters:arm64 1.28.7-1+deb11u1 1.28.7-1+deb11u2
2023-05-23 10:44:04 upgrade libwebp6:arm64 0.6.1-2.1 0.6.1-2.1+deb11u1
2023-05-23 10:44:05 upgrade libwebpdemux2:arm64 0.6.1-2.1 0.6.1-2.1+deb11u1
2023-05-23 10:44:05 upgrade libwebpmux3:arm64 0.6.1-2.1 0.6.1-2.1+deb11u1
2023-05-23 10:44:05 upgrade linux-image-6.2.0-1-librem5:arm64 6.2.10pureos2 6.2.13pureos2
2023-05-23 10:44:11 upgrade linux-image-librem5:arm64 6.2.10pureos2 6.2.13pureos2
2023-05-23 10:44:11 upgrade linux-libc-dev:arm64 6.2.10pureos2 6.2.13pureos2

So I have to revert those…

sudo apt-get install ./linux-image-6.2.0-1-librem5_6.2.10pureos2_arm64.deb ./linux-image-librem5_6.2.10pureos2_arm64.deb

should do the job. Right?

Just to add something in case it helps debugging:

I have mobile with 2G 3G 4G preferred. With this it connects to 2G. No calls work no internet.

If I switch to 4G only, I still have no calls but internet does connect.

Do you have volte enabled via the bm818-tools utility?

1 Like

Yes but it never worked. It always drops to 2G when in a call.

I suspect that non volte support got turned off in your area. I believe turning on volte requires cycling the modem (or just rebooting the phone) to apply. Could you try:

  1. Enable Volte via the bm818-tools
  2. Reboot the phone, or flip the modem kill switch to off, wait 30 seconds and flip it back on.

If that doesn’t work I’d suggest reaching out to purism support, they’ll be able to help with that better than I. You may need to update the firmware on your modem(any purism support knows how to do that).

1 Like

Thanks. I will first contact my carrier to make sure there is no issue there and then contact support.

I downgraded and it still does the same. So I suspect a problem with the carrier. Maybe the turned off something in my area as you say.

1 Like

I would expect so and it seems like a warning would be appropriate - but it should in theory be valid to make a call, receive a call and continue a call even with no microphone. So the warning should be advisory but it should not stop you going ahead.

An added complication is that even if the mic HKS is off, you may have attached an additional sound source - and the operating system may or may not attempt to disable additional sound sources. In other words, the H part of HKS only applies to certain built-in components.

1 Like

Reporting back… I didn’t know about bm818 tools and it did the trick for me. The voice quality is way better via LTE.

(I’m in Europe)

1 Like

@antonis: What is your modem firmware version? Use bm818-fw-check in the terminal to check.
I have:

$ bm818-fw-check 
chat:  May 24 09:36:16 +BMSWVER: M100E_YCSN0_1.0.0_220926,YCSN0_M100E_1BAD_3117_V1.0.0.2_20220930,M100E_1.0.4_200715

Although I still do not have VoLTE working, it turned out that the problem was not with the phone but it was a problem with the carrier and their roaming. It turned out that last night travelling by car on Samos island the phone got connected to Turkey. This they told me locked the SIM. Next morning I upgraded the phone and then realized it did not work, and I thought it was the upgrade.

They disabled roaming on their system and a reboot of the phone solved the issue. Of course if I travel abroad I have to ask them to re-enable roaming for me.
So all this was a false alarm as far as L5 is concerned.

But to add something in the positive direction, I remember that some android phones have an option to lock the phone to connect only to a given carrier and not select the stronger signal. Maybe this could be a useful feature to be added.

As for the bm818-fw-check I get exactly the same output (except for the time on May 24)

Thanks everybody who tried to help me.