L5 won't boot anymore

Hi there,

I received my Librem 5 end of last year. Back then I checked the functional state of the phone and its apps and saw that it was not yet fit for daily use for me.

Since then I am loading and firing it up at least once a month to run upgrades using the corresponding app and to check the progress. I also installed new apps to have a look at them.

During the last update a popup came up that space in boot would be low and it did not start properly after the reboot.
I was able to enter the decryption password, the librem 5 logo appeared shortly afterwards but then nothing happened anymore. The screen still seemed to be on and the phone became very hot, but that was it.

I also tried to display the messages while booting via the button combination, but I was not able to keep them on the screen long enough for me to read.

What is the best way to get it up and running again ? Is reflashing adviseable in such a state?

And is Purism aware that their standard upgrade, installation (and deinstallation) mechanisms that have been foreseen for normal end users do not work properly ? (When the phone was still working I also tried to deinstall some apps I installed previously, it never worked)

Thanks in advance for your hints! :slight_smile:

1 Like

I am a user not affiliated with Purism. But I have been trying to use my phone instead of the locked down bad ones as much as possible since I received it in Apr.

And mine sometimes does like you describe in the sense that it shows decryption login, gets to Librem 5 logo, then goes black. Maybe one a week, not very frequently. In those cases I boot it again and it works!

So I have no idea if this helps you, but I wanted to share that this sometimes worked for me. Good luck.

1 Like

I have the exact same problem. I also got the popup that space in boot would be low. That is obviously a bug in the update process, because what can I do as a user to prevent or fix it, nothing. This should not happen in the first place. The update-process has to make sure old stuff gets deleted from boot.

After that I saw that there is a new update, so I did that update, because I also hoped it would fix the boot problem. But now my Librem 5 is bricked. Same thing, after entering the decryption pw it’s looping on a blackscreen. The background LED goes off for a quick moment then turns on again. So it’s looping between almost black and fully black. When I press the power button I quickly see the Librem Logo, then the phone shuts off.

How can we fix this?

Reflashing is not a problem (and it’s the fastest thing in case you don’t have any data to lose). Otherwise recovering with jumpdrive would be an option.


Thanks for the quick reply. Where do I find the tools and image to reflash it?

See my post in a different thread below.


I had the exact same problem. I did the reboot put in the decrypt password then a message popped up not sure exactly , crtl C something, L5 appeared to stop, I happened to leave the phone as it was, I went to my PC to search for a solution. I came across some post that mentioned that the message usually pops up quickly and mostly it is not noticed, but nothing much else. I was away from the L5 about 30 mins. When I returned I found the reboot completed ok and the L5 was working properly again. I guessed that there was some long running process that activated after the last upgrade.
FWIW I notice PUREOS Store is not upgrading properly. I am using apt-get update and apt-get upgrade to do update now,
I think I should mention that I also got a message about low boot space.
I connected to my dock and tried to clean up some files. When I tried to empty Trash it failed. I needed to use Terminal and sudo rm --recursive ~/Trash/* to delete the files in trash.


On my Librem 5 size of the /boot folder ( partition /dev/mmcblk0p1 ) is 450M. A the moment I have 45% free space. On this screenshot you can see content of this folder.

Each time when you do a kernel update this space is taken with new kernel files ( System.map.xxxx, configxxx,initrdxxxx, vmlinuzxxxx and /grub folder ).

That’s why you got this warning about /boot folder low space.

What to do?

After each kernel update:

  • Issue command “apt autoremove” ( or “sudo apt autoremove” if you are not logged in as root user) to delete oldest kernel files

  • Reboot Librem 5


I am not using built in PureOS Store for any Librem 5 updates or other package management.


My L5 is my daily phone. Now I have MMS working I am very happy with it.
I was getting the occasional issue where the caller could not hear me. Turns out because of daily use there was a small buildup of dirt in the audio switch that moved the switch to off. So I need to daily check and keep the switches clean.

Dear all,

Thanks a lot for your answers and suggestions, I will try to reflash my L5 and hope that this helps.

1 Like

Thanks a lot for your advice!
How can I report the update cleanup issue so that it can be fixed ?