Laptop won’t power on

I purchased a new Librem 13 in May so about two months ago. It was working well until today. Out of nowhere the screen turned black, and I was unable to do anything at all. I held down the power button to shut it off, waited a few seconds, and tried to turn it back on.

The lights came on, but then shut off again, leaving only the light left of the orange charging light to blink lightly every few seconds.

I tried holding down the button again which did nothing. I tried again for around 10 seconds, and the right light turned on again for a second and shut off again.

I used a pin to reset the laptop, and tried to turn it on again. The same thing happened, the two lights turned on briefly, then shut off, leaving only the left light blinking lightly every three or four seconds.

Another issue I had which I’m sure is unrelated, but seems worth mentioning, recently when I would turn on the laptop and type the password to unencrypt it, it showed “cryptsetup: error: bad fstype” with more text I can’t remember, then it said “maximum number of tries exceeded”, but would proceed to start up normally.

I really dont understand what’s happening though as it was very new and seems to have just stopped working altogether out of nowhere.

Sometimes this can happen because of the faulty battery. You can try disconnecting the battery and try starting the laptop with AC in. If it works—the battery is dead. If it doesn’t—the laptop is dead.

Can you add a link to where I can get info on how to take out the battery on a Librem 15 v3 TPM?

Mine shut down while I was away at work and it’s completely unresponsive

@EricClarke you can see how to disconnect the battery here:

Thanks! Not sure why I asked twice - but my internet has been up and down like a toilet seat since the weekend :slight_smile: - I’ll pull the battery and take it from there. Cheers!