Last update is breaking zsh

On byzantium, I executed :
sudo apt-get update
sudo apt-get dist-upgrade

but it removed zsh

I tried to reinstall zsh after the update, but I have this error:

The following packages have unmet dependancies:
zsh : Depends: zsh-common (=5.8-6) but 5.8.6+deb11u1 is to be installed
E: unable to correct problems, you have held broken packages.

here is the history.log:

Start-Date: 2022-02-16 21:51:45
Commandline: apt-get dist-upgrade
Requested-By: purism (1000)
Upgrade: zsh-common:arm64 (5.8-6, 5.8-6+deb11u1), librem5-base-defaults:arm64 (46pureos1, 47pureos1), libexpat1:arm64 (2.2.10-2, 2.2.10-2+deb11u1), librem5-base:arm64 (46pureos1, 47pureos1), flash-kernel:arm64 (3.102.0pureos4, 3.102.0pureos5), librem5-gnome-base:arm64 (46pureos1, 47pureos1), linux-image-5.16.0-1-librem5:arm64 (5.16.3pureos1, 5.16.7pureos2), firefox-esr-l10n-fr:arm64 (78.14.0esr-1~deb11u1, 91.6.0esr-1~deb11u1), librem5-gnome-phone:arm64 (46pureos1, 47pureos1), librem5-non-gnome:arm64 (46pureos1, 47pureos1), librem5-gnome:arm64 (46pureos1, 47pureos1), libflatpak0:arm64 (1.10.5-0+deb11u1, 1.10.7-0+deb11u1), flatpak:arm64 (1.10.5-0+deb11u1, 1.10.7-0+deb11u1), linux-image-librem5:arm64 (5.16.3pureos1, 5.16.7pureos2), firefox-esr:arm64 (78.14.0esr-1~deb11u1, 91.6.0esr-1~deb11u1), librem5-devkit-base:arm64 (0.0.22pureos1, 0.0.24pureos1)
Remove: zsh:arm64 (5.8-6)
End-Date: 2022-02-16 21:54:25

The package zsh has the dependancy to “zsh-common 5.8-6” but “zsh-common 5.8-6+deb11u1” is installed

I’ve switched back to bash … :roll_eyes:

You broke zsh, dist-upgrade upgrades even if a package needs to be removed or a conflict to be resolved and I think it asked you before doing it, next time just do the normal sudo apt upgrade unless you need to do it so.

zsh needs to be updated as the version number of zsh-common dependency does not match

1 Like

I finally forced the good version which is still available
sudo apt install zsh-common=5.8-6

This zsh dependency issue is now solved in PureOS. So it can be updated or reinstalled.

Hey @joao.azevedo :slight_smile: I believe I’m at the latest version and I’m still getting the error shown above:

$ sudo apt install zsh
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zsh : Depends: zsh-common (= 5.7.1-1) but 5.7.1-1+deb10u1 is to be installed
E: Unable to correct problems, you have held broken packages.

Seems like it’s a problem on your side, did you do sudo apt update before install ?
Version 5.8.6 is the current one available, not 5.7.1

1 Like

You aren’t, as @fralb5 just confirmed. But at least one from bellow should help there, while pointing toward 5.8-6+deb11u1, when indeed used byzantium and byzantium-security repos:
apt list zsh zsh-common
sudo apt update && sudo apt upgrade
sudo systemctl reboot
sudo apt update && sudo apt full-upgrade
apt list zsh zsh-common
sudo apt install zsh

Yes thanks team, I see I’m in fact on amber, not byzantium.

Now I have two problems :stuck_out_tongue:

In the process of trying to upgrade now. Thanks for your help and quick responses @fralb5 and @Quarnero :bouquet:

1 Like