Liberty Tunnel - PureOS


#1

Hi - I recently subscribed to Librem One, and am attempting to set up the VPN tunnel on PureOS running in Virtualbox, so I can extract the OpenVPN information for use.

My PureOS install is up-to-date and I followed the instructions posted for setting it up using pipx. However, when I try to login, I get either:

Something went wrong when connecting to https://librem.one/api/v1/user/tunnel_account
Problem Details: Invalid username/password (when I follow the instructions exactly)

or:
Something went wrong when connecting to https://librem.one/api/v1/user/tunnel_account
Problem Details: Internal Server Error (when I use my full @librem.one address to attempt to login).

I have verified that my password is correct as the app works fine in iOS.


#2

Hi @benunger,

Try to do the login process in Tunnel using only username and not username@librem.one.
Like shown in the images here: https://docs.puri.sm/Librem_One/PureOS/VPN_Tunnel.html#configuring-librem-tunnel

And indeed this tutorial could be more specific about this part. We will change it to highlight that only username is required.

And let us know if this solved your problem.


#3

I did solve the problem; however, I am still not able to connect to the VPN using the imported *.ovpm and *.pem keys.


#4

I had to restart after install to get mine to work.


#5

Could someone tell me how to get the Librem VPN to automatically connect? Every time I close and re open my computer I have to manually re connect…