Libmtp error: Could not get file from device

Operating system: pureos byzantium with gnome desktop ( up to date , 1 uninstallable update (libglib2.0-bin) )
problem: -Connect android phone via usb port to device.
- Select option MTP.
- Can open internal storage and see the directories.
- Tried to open a photo, video get ‘libmtp error’.
-Tried to copy photo to documents folder get ‘libmtp error: Could not get file from device.’
- Tried other android phones and different usb cable same error.
Recently I installed mate desktop environment , noticed this error , installed gnome , removed mate desktop.

when i run sudo mtp-detect i get:
libmtp version: 1.1.17

Listing raw device(s)
Device 0 (VID=17ef and PID=7928) is a Lenovo A1000 Smartphone.
Found 1 device(s):
Lenovo: A1000 Smartphone (17ef:7928) @ bus 1, dev 4
Attempting to connect device(s)
error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device
Unable to open raw device 0

Do you have your phone set to allow file transfer via USB? Sometimes it sets itself to “charging only” and the computer can’t access it in that mode.

This issue doesn’t seem to be there now . can someone close this as irrelevant. I have no clue why it happened before.