Libre Mini HDMI issue


I can run PureOS on my mini from a USB stick as long as I select failsafe mode. If I install the OS or don’t select fail safe mode when running from the USB then the system doesn’t boot. It begins to boot but then it just keeps turning off the monitor and turning it back on.

It doesn’t seem to be a full boot loop because my keyboard doesn’t turn off and I don’t see the SeaBios screen again.

I tried another OS (Debian) and the result is the same. Everything works during the install process but when it comes time to boot I get nothing.

I’m using the HDMI output, I also noticed when PureOS boots up the display is briefly scrambled with lots of pretty colours. I don’t know if that’s related. I’m getting a display port adapter tomorrow so I can see if the problem is due to the HDMI port.

Anyone else experience anything like this?

I made a video that will hopefully show the issue a little more clearly.

Do you know what the date is on the ISO file? Try the newest Live ISO and see if that helps:

Also don’t forget to compare the checksum to make sure it didn’t corrupt upon download.

I downloaded the ISO yesterday. I only got the Mini yesterday, so it’s brand new. I have the same issue with Debian.

Something else I’ve noticed. If I unplug the HDMI and then plug it back in, while the system is on, I get the same result with the monitor disconnecting and then reconnecting.

Ok more progress, and I should change the title of this topic. The mini does boot. I was able to login, open the terminal, and reboot the system (without being able to see anything of course). So this seems like some kind of graphics hardware/software issue.

I found that adding nomodeset to the boot thingy allows the non-failsafe live image to work.

Glad its working for you now. Just note the Librem Mini can be finicky with more inexpensive HDMI cables. Try a different cable or DisplayPort.

1 Like

Well it’s kind of working, still having some weird behaviour, but it’s usuable for now. I’ll try out some other cables and the display port especially.

I updated to the latest coreboot and that removed the need for nomodeset. However there is still some weirdness, if I unplug the cable and plug it back in I still get the screen going on/off. I’ve tried 3 cables now, each with the same result. I’ll try the displayport tomorrow and report my results.