Libreboot X200 with PureOS Playing Videos

I was wondering if anyone currently uses PureOS on a Libreboot X200. Are there any considerations that would prevent it from working well (PureOS devs)? I’ve tried it, and sometimes videos are choppy in VLC or Totem (but not in the web browser). Is there possibly a way to fix this, or is the hardware just too old?

Is this a stock spec X200? How much memory is installed? I would think that a 4-8GB RAM version with an SSD would be fine for the above tasks, but that is pure speculation on my part since I do not personally own one. I base my opinion purely from what I’ve read online and watched in video form.

My X200 has an SSD, 8GB of RAM, and a 2.26 GHz CPU.

That’s a bit vague, what kind of videos? What codecs, what resolution and framerate? What do you mean by “choppy”: frame drops, corruption artefacts, or tearing?

I doubt PureOS is doing anything special on that front. I’m very surprised that the same videos would play smoothly in a web browser though, my experience over the years has usually been the other way around.

If you’re expecting 4K or VP9/VP10/HEVC video playback on a 2008 laptop however, I have some doubts that it would work :wink:

So, it happens with any video, if I play them for long enough. As for the specific codecs and framerates, I have no idea, actually, about that sort of thing. I can tell you that it happens regardless of format (I’ve tried .ogv, .mkv, .mp4, m4v, etc.), media player (vlc or totem), or size (a few megabytes up to several gigabytes), and it won’t go back to normal until a full reboot.

If you happen to have access to a Librebooted X200, you could try it yourself; just install PureOS (and make sure that all the packages are up-to-date), download a video that’s fairly long (about 2-3 hours, or so), or several shorter videos, and start watching; it’ll start out playing normally, but then the video will eventually start to play like it’s shot in slow-motion, and skipping frames.

I don’t have access to that hardware, and I don’t have time for testing such things (just “dropping by” by chance to throw in my questions and help). If it happens with any video, is duration-based, and takes a poweroff to calm things… are you sure your system is not overheating and throttling itself? Is the cooling system really clean? Does it happen with another Linux distro? Does it happen with a different desktop environment (ex: KDE, XFCE, etc.)?

1 Like

I have a netbook with AMD zacate system. The thing is doing great job (1080p 60 fps smoothly) in Microsoft Edge, but in Linux with Firefox, movies are choppy (even simple 720p). The issue is that Firefox has blacklisted some graphical drivers.
So maybe 2 things to investigate :

  • did you have checked if this issue happen in Firefox, especially Linux distro ?
  • about VLC, did you have installed drivers and enabled hardware acceleration in “codec” section ?

Hope it will help
PS : If you have any solution about my choppy videos in Linux, please feel free to tell me.