Librem 13 arrived, screen blank


#1

I have plugged in my newly received librem 13.

The screen is blank.

I see an orange light in the center, with white lights on both sides. After additional charging, the center light turned white.

Pressing the power button turns off the white lights.

Pressing the power button again turns the white lights on, but I don’t see anything on the screen.

What should I do?


#2

It seems like a hardware issue, but just in case,I would try making a Live-USB of PureOS (or any other Linux distro) and try booting from that.

You should also email support@puri.sm


#3

Thanks. Tried Qubes USB with no luck, and waiting for response from support


#4

In situations like these it is always a good idea to use the reset button: use a paperclip to press and hold it for few seconds (make sure the device is unplugged).

We will have a troubleshooting guide (soon I hope) with this and other troubleshooting steps.

@nereocystis contacted @support and we’re handling from there now.


#5

When that happened to me, it turned out the memory module had come loose. Trivial fix, if you have a tiny screwdriver.


#6

Thanks @SteveC

Resetting the memory did the trick. I had tried it last night, but was a bit rushed, and had not fully pulled it and reinserted it. Today, I fully reseated it, and it worked.

I did upgrade the memory to 32GB. I wonder if testing was done before memory was upgraded.

@mladen Thanks for your suggestion also. Unfortunately, the reset button did not work.