Librem 13 regularly abrupbly crashing

When I use my laptop, when it’s not plugged in, it tends to crash very suddenly with no warning. You can tell how regularly this happens in that I have memorised my 20 digit core password now. It happens almost every time the laptop is not plugged in, which is rarely. This means I have to lump the heavy cable around where ever I go and prevents me using my laptop outside (easier to borrow my work one, which can reliably run on a battery for a few hours). Mladen sent me a new battery and I installed it, but no luck.

I unexpectedly found that under settings, Power, there are various options for the Suspend & Power Button that appears to depend on the battery power. When the Power Button is pressed I can choose -nothing, -suspend, or -PowerOff.
Now I type it out it seems unlikely, but I’m hoping: Is it possible that I was accidentally hitting the power button (positioned where I am used to having a delete button) and it was then crashing (powering off) the laptop, but only when the laptop was on battery? But not doing anything when it was plugged in. And also not warning me, not telling me that programs are running, not asking me if I want to save anything first. Just very abruptly shutting down.

Anyway I’ve switched that option to ‘never’ so in case that was it, my laptop might stop regularly switching off while I’m in the middle of something.

Has anyone else had problems with the laptop suddenly crashing, pretty much every time you are on the battery (perhaps it’s just until I accidentally hit the power button).

1 Like

Does your laptop completely power down, or just go to sleep? When you log back in, are the programs you were running still open and where you left them, or is it a clean slate?

It completely powers down. I need the long 20 digit password, not the one for just logging in. All my programs are shut down and I’m reliant on the automatic backups for all the files that were open.
I wouldn’t describe it as abruptly crashing if I meant ‘goes to sleep but wakes up fine, where I left it, when I plug it in’. Which it does not do.

Just wanted to be sure.

It honestly sounds to me like a wonky battery, but if Mladen shipped you a new one, I’m not really sure.

I do this many times each day because I use different keyboards. Not once has a momentary press on the Power key turned off my Librem 13 v2.

And what is your setting for the power key? Perhaps you have it set to do nothing already. I’m persuing this because I really hope this magically fixes the problem and I ran my laptop down to around 35% yesterday and it didn’t crash (which is not yet proof, but it’s a good start).
They setting in question is very bottom radio button, currently showing ‘nothing’ (alternatives are ‘suspend’ and ‘power off’).

It’s set for Power Off.
It does Power Off it i press and hold the Power Key for about one second.
Actually, it gives me the dialog box about automatically powering down in 60 seconds- it does not immediately shut down or turn off.
If I just momentarily press the Power Key, nothing happens

Yes that sounds how I’d expect it to work, with the dialogue box.
I don’t get any dialogue box, just a blank screen and my work lost (apart from the automatic backups).
Well I’ll see if it’s still crashing next time I’m working on something non-essential.

I’ve been having the same problem. I’ve starting taking notes so I can see what the commonalities are. It looks like it may only happen when I’m on battery. When I power back on and look at the battery charge, there is always ample charge. It’s a total crash, black screen. I have Librem 15 ver.3, and I’ve had it for a year, but the random crashes have only started happening in the last maybe 2-4 weeks.

1 Like

I’ve tried experimenting with running the computer only on battery and running the computer from the power supply. The crashes only seem to happen when I’m running on battery.

1 Like

could you find a cause? I’m running into the exact same scenario. Librem 15v3, sudden power off, but only on battery, ample power left when turning on again.

Sounds similar to the problem discussed here:

1 Like

My guesses about what is going on: I think the battery may be somewhat faulty. At the time that I made my blog post about this, I was still within the 1 year warranty period, and they sent me a new battery. However, I still have the same problem with the new battery. What’s happening is the power on the battery is running out, but the % power that it says is available doesn’t accurately reflect the amount that is actually there. Support sent me some directions to reset the battery, but it didn’t help. The other problem is that when the battery power runs out, it’s not going into sleep mode, instead it’s doing a hard crash. I think there is a file you can change to setup your sleep options, but I never got around to playing around with that. I still have the same problem, so when the battery starts to say around 50%, I get nervous and plug it back in. That’s my workaround.

I resolved the problem by buying an apple mac.

Another possible influence is there appears to be some sort of electrical issue. When I plug in the computer, the mouse can become erratic (which I had reported in a previous blog post a couple of years ago). Whereas, if I ground myself using a grounding pad, the mouse acts normal and is no longer erratic. So I wonder if there is some sort of electrical issue that is affecting the battery and its interface with the computer. However, my problem of the hard crash only happens when the % on the battery is around 50% or less. It doesn’t happen at higher percentages.