Librem 13 v2: How to enable VT-d / IOMMU?

What is the best way to enable the Intel VT-d extensions for IOMMU? qubes-hcl-report is showing IOMMU is not active.

SeaBIOS is only showing three options: boot from disk, memtest, and coreinfo.

Coreinfo seems to be corrupted? Just shows wide green and black lines, no info.

If I understand correctly, coreboot has no UI for doing any config; config must be done when you install/flash it. If you want a runtime config UI you need to install coreboot with the nvramcui payload, however it is not clear whether nvramcui will allow to change VT-d/IOMMU settings.

1 Like

So, a failed attempt. Rather than reinstalling with nvramcui, I tried using the nvramtool utility from userspace Linux. (From package coreboot-utils on Fedora. Maybe nvramtool on Debian.)

Installing on Qubus dom0: sudo qubes-dom0-update coreboot-utils

However, when running sudo nvramtool -a, it says “coreboot table not found. coreboot does not appear to be installed on this system. …”

So that didn’t work. Not sure whether flashing a new coreboot with nvramcui would give different results. Maybe Xen is somehow preventing dom0 from accessing the nvram flash?

So, that was a fail. Some interesting info here which I haven’t yet fully parsed through and tried to act on: