Librem 13 v4 unrecognised M2 drive

Just upgraded my old Librem 13 with a new 32Gb ram stick and a 1Tb drive in the M2 slot. RAM went in fine, and it’s loving the new room :slight_smile: But nothing is recognising the M2 disk. Nothing showing on fdisk or gparted. Tried re-seating it a couple of times, there doesn’t seem to be anything going on with it.

My gut is telling me there’s something in the BIOS config, so I ran the coreboot update script to update the firmware, but I can’t find anything in the SEABIOS or Coreboot docs about this.

Anyone bumped into this, or got any clues?

Does it get recognized in GNOME Disks or during the Calamares installation with PureOS?

Gnome Disks doesn’t show it. I haven’t bumped into the Calamares thing at all.

Okay, any chance you have a different device with an M.2 slot? If you do, try installing it there and see if it gets recognized.

1 Like

We bought 2 identical drives. One went in the wife’s gaming machine and works fine, the other in my laptop and isn’t being recognised. I know it’s always possible that I bought a dud drive and that I should test it, but I’m having a hard time justifying the effort of swapping them over :wink:

1 Like

Sure, take your time.

haha. OK, fair point.

1 Like

I bought several Samsung 120 GB drives of the size of a laptop drive, for use with an Lenovo X-230. None were recognized at boot time. I tried several live Distros of Linux.


I tried the USB of Windows 10. No problem. Windows saw it. Formatted it as NTFS for use with Windows. I actually let the installer run on to see if the result would work. My guess was that anyone who wanted to sell hardware, had to make sure it worked with Windows.

After ward Linux Distros would see drive, as would “Live USB Linux distros.”

A better solution would have been to get external case for the drive. Format it off a Linux Distro.

Long, when I was using a desktop. Used to be, each of the hardware manufacturers of drives, Seagate, Western Digital, and so on had a CD to format their own drives the first time. I wonder if the manufacturer of your drive has a "Live USB " for just your situation.

thanks :slight_smile: good tip. I ordered an external caddy for M2 drives so I can plug this into the gaming machine and see if it works :wink:

I forgot to say, my Librem 13 V2, right now, has problems recognizing Qubes 4.2 Installers after - about the end of August. Will not see Qubes 4.2RC3 or Qubes 4.2 Rc4. The drive in my Librem 13 V2 was owner installed, not from Librem - the manufacturer of the Librem 13.

I installed Qubes 4.2 from early August 2023 (Weekly signed Qubes site not an official Qubes site. - but then I see a note that a lot of mirror also have a warning that they are not official Qubes sites.)

I have updated that to the latest. I had to say all that to admit another issue. After I started my Librem, I touched the Librem Key and the computer immediately said, the key had been removed. Then it reset and said the key was in place. Not cool. Looks like the USB slot is flaky. Still, I don’t think that is the same problem as not being able to see the internal drive.

Are you saying, right now you have two drives in the computer?

That is one of the symptoms of the later Qubes not being able to be installed.

In your case, I wonder if the Pure Boot needs to be reset somehow.

And as I think of it. Besides buying an external case for the drive. You might just put the Windows 10 Installer on a USB key. Boot to the Windows Key. Just back up what ever is on the second drive. Which should not be clobbered by letting Windows format the other drive. Cross fingers.

I dont now if this is helpful.

I have a 2TB samsung 970 evo ssd in my L13 v 4 which came with the laptop…and bought off the shelf from amazon a 2TB samsung 970 evo and was able to clone and use the drive interchangably with no issues. Maybe hardware compatibility? IDK.

Problem solved.

Bought a USB caddy. Put the drive into a Windows machine and used the Disk Manager tool in there to add a MBR. Once that was done, put it into the Purism laptop and it recognised it as dev/sdb no problem. Formatted it to ext4 from there. Then moved it out of the caddy and into the laptop itself and it recognised it as dev/nvme0n1 no problem.

Pain in the arse, but we got there in the end :wink: