Librem 13v4 not connecting to wifi


#1

I just received my Librem 13 Saturday and out of the box the wifi worked fine. The first thing I ran was sudo apt update && sudo apt upgrade . after running and installing all the updates and upgrades I ran sudo apt autoremove and shut down the laptop. after turning it back on I cannot connect to the wifi. I tried to restart the network manager but that did not help, I have also changed the DNS to 8.8.8.8 but this did not help. Now I cannot run updates or upgrade because I cannot get onto the wifi but all my other devices connect fine. Can anyone help? Thanks.


#2

Check syslog to see whether anything is being logged that might shed light.

Try iwlist wlan0 scan to see whether you can even see your access point. (wlan0 is the name of your wireless interface. If it isn’t that then replace with the actual name.)

Connect to your access point (router?) from another computer and see whether the access point itself is giving any useful information.

(Not a fan of computers without ethernet ports. I keep a USB-to-ethernet dongle around just in case.)


#3

When I run iwlist wlan0 scan it tells me “Interface doesn’t support scanning.”


#4

Since this is a brand new laptop, you might try making a formal support request with Purism.


#5

Is the interface you want to scan named wlan0? I ask because when I issue the same command you did, namelyiwlist wlan0 scan I get the same error message you do. But when I use nmcli to find the names of my network interfaces, I see something call wlp1s0

$ nmcli
wlp1s0:

Then, I can run iwlist on that;

$ iwlist wlp2s0 scan

which produces a lot of results here. Try the nmcli command to see if you can find the exact name of your wireless interface.


#6

OK, that looks like a “predictable network interface name”, irony intended.

Whether an operating system is using the predictable network interface name functionality depends on the exact distro and version (and maybe even the history of upgrade - I have some Linux computers that have been upgraded from a version before that functionality existed and in that case the functionality politely disables itself on upgrade).

Not a huge fan of predictable network interface names for this use case.