☑️ Librem 14 boots into emergency mode after EC flash

After flashing my EC firmware, I now get bumped into emergency mode, with what appears to be a broken polkit…

I followed the guide for flashing my EC, then signed the new files in /boot since I did a kernel upgrade a little while back.

The flash went well, and I booted into it a second time to verify all went well. When I tried booting into PureOS, it wouldn’t let me.

journalctl -xb showed a mostly correct boot, but some things stood out…

From the looks of it, an Intel firmware didn’t load, and something messed up polkit (and by extension, brltty).

What caused this, and how do I fix it? I’ve not really messed with this machine much, just installed Vim and a few extras. Everything was working fine before I flashed…

I have a few more ideas I’ll be trying, but this is a first for me in terms of error messages. Any insight would be much appreciated!

EDIT: Wow… One of the things I did prior to flashing was add some entries to fstab for an external hard drive. However, I omitted noauto from the options by accident, and failing to mount those devices at boot prevented systemd from finishing the graphical.target unit.

Now I’ll be looking for ways to make systemd ignore mount failures. There’s no reason that should’ve stopped boot, since the onboard storage of the Librem was mounted and working just fine.

EDIT2: For good measure, add nofail to the mount options so that it explicitly won’t care if it’s not there; though the noauto achieves the same result for you on boot by not trying to mount it.