Librem 14 - DKMS EC ACPI module not automatically installed on kernel update in dom0 with Qubes


This is a Qubes OS specific issue, and I am posting it here to start because I doubt anyone other than Librem 14 users running Qubes are needing to install DKMS modules into dom0.

I’ve noticed that the DKMS EC ACPI module does not get automatically installed when dom0 installs a new kernel. Upon reboot of dom0, I have to manually install the module again using the following command:

sudo dkms install librem_ec_acpi/1.0.0

I know that support is recommending Qubes users to use DKMS to install this module following the instructions @Kyle_Rankin provided at, which is about the same as I described in this forum post back in June. The only difference is the DEST_MODULE_LOCATION, /extra/ vs. /updates/dkms/.

From what I can tell, DKMS modules don’t get autoinstalled on new kernels because the dkms systemd service is disabled by default in dom0.

Has anyone else ran into this issue? If so, did enabling the systemd dkms service fix it for you?

I enabled the systemd dkms service in dom0 using:

sudo systemctl enable dkms

I’ll report back my findings whenever a new dom0 kernel is released.

dom0 received a kernel update today. I can confirm that the dkms systemd service rebuilt and reinstalled the EC ACPI module upon system reboot.

1 Like