Librem 14 Doesn't Detect Charger and Not Charging

Hello, this morning I started doing work on my laptop and noticed that even though I had the barrel jack charger plugged in, the laptop was still discharging. The battery was below the charge start threshold and I tried making the threshold below the current battery and then higher than the battery to force it to charge but that didn’t work. I have spent some time scouring the internet for similar problems and tried a few solutions, but nothing has worked. The charging worked fine last night, but just randomly stopped this morning even though I didn’t change anything. I tried updating the EC too and am now on the latest version, but I still have the problem.
This is why I think the charger is just not detected. (I ran this while the charger was plugged in):

user@host:~$ upower -i /org/freedesktop/UPower/devices/line_power_AC
native-path: AC
power supply: yes
updated: Wed 21 Jun 2023 12:39:35 PM MDT (1492 seconds ago)
has history: no
has statistics: no
warning-level: none
online: no
icon-name: ‘ac-adapter-symbolic’

Any help is much appreciated and just let me know if you need more information, thank you!

This was a hardware issue present on my laptop, that other people also ran into. Use your warranty (Purism or credit card) if available. Could also be potentially fixed with solder.

I believe my warranty has expired and I would love to avoid shipping it off either way. Is there a way I can check to make sure it’s a hardware issue? Like any visible signs for a non hardware-savy person?

I would reset the BIOS… First unplug power, then unscrew the bottom of the laptop. Located the CMOS battery and disconnect it from the motherboard. Wait a couple minutes and plug back in.

Mind you if you have Pureboot it might reset something so you would have to reconfigure some settings.

Plug power back in and see if that helps.

I don’t think there is a CMOS battery. However removing the laptop battery may be worth a shot.

I just ran into this issue as well last week. There is a CMOS battery in addition to the main laptop battery. I tried fully disconnecting both, but in my case, it did not work. I contacted support and sent my laptop back to Purism for service.

Of course there is. The CMOS battery (a.k.a. BIOS battery) is located as discussed here: