Librem 14: Installation process ends with freezing

Attempt to reinstall with USB stick

Installation running

Installation completed
At this point today I was three times.
When restarting, the system freezes.
After pressing Ctrl, Alt + Del and restarting

After that only a black screen with blinking cursor follows.


Have you tried installing PureOS 10?

1 Like

With the delivery yesterday I received a stick with PureOS 9.
I have not tried PureOS 10 yet.
I will try it.

I don*t find the download-link

Next try PureOS 9, as I can’t find PureOS 10.

Has anyone tried to install a system encrypted via LUKS with a separate data partition?

Unfortunately I failed according to instructions

  1. Manual partitioning

  2. New Partition Table

  3. GPT

  4. Free Space --> Create --> 8 MiB File system unformatted bios-grub

  5. Free Space --> Create --> 70000 MiB Filesystem --> linuxswap Encrypt

  6. Free Space --> Create --> 40000 MiB Filesystem --> ext4 Encrypt --> Mointpoint /

  7. Free Space --> Create --> 40000 MiB Filesystem --> ext4 Encrypt --> Mointpoint /home

  8. Free Space --> Create --> Rest of Space MiB Filesystem --> ext4 Encrypt --> no Mountpoint

And then:

Installation Failed

Boost.Python error in job “bootloader”

Command ‘grub-install --target=i386-pc --recheck --force /dev/nvme0n1’ returned non-zero exit status 1.
Installing for i386-pc platform grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible. grub-install: error: embedding is not possible, but this is required for RAID and LVM install.

I believe this is the PureOS 10 download.