Librem 14 - Intel AX200 Setup and Config

I recently install the AX200 wifi/bluetooth module in my L14. Wifi works fine after installing firmware/driver. Having issues getting bluetooth to work. Any ideas?

Get a Bluetooth USB adapter.

haha, thats the only way huh.

There are many ways to solve the issue, but I am suggesting an accessible and practical solution.

I won’t be able to resolve this but the basic information required would be:

  • what you have tried, and
  • what error messages you received.

I assume you are running PureOS.

What exactly did you install when you installed “firmware/driver” for WiFi and how did you install it?

Given that Purism recently announced that new orders for the Librem 14 will ship with the Intel AX200, it may be as well to confirm with Purism that in that scenario Bluetooth will work.

However the procedure for creating the firmware jail and getting the firmware in there may be tricky. You would probably have to ask Purism for clues. That is to say, I assume that you received your Librem 14 some time ago and it may not even have the firmware jail and/or the firmware is probably not in there if your Librem 14 shipped with the Atheros card (my assumption).

1 Like

Because you need Kernel OS plus FOSS OS and Gnome OS, GTK OS, Torvald OS all together to get it work like a fancy. :sunglasses:

I know this sounds strange, but instead of doing a reboot … try doing a poweroff and see if it is fixed after powering it back on. i.e. So “systemctl poweroff” instead of “systemctl reboot”.

Also, have you examined the logs and asked for the status (e.g. “systemctl status bluetooth.service”) …?

See drivers - Intel AX200 Bluetooth not working in Ubuntu 22.04.1 LTS - Ask Ubuntu

1 Like

Bluetooth has its own firmware: blobs/librem_jail/librem_14/intel · purism_next · firmware / PureBoot · GitLab

Please note these need to be in a subdirectory named intel of the firmware directory (which is why they are in an intel subdirectory in the repo).

If you drop those files in /lib/firmware/intel/ and then reboot or cycle the Wi-Fi kill switch, that should be all it takes. If it still doesn’t work, check for firmware-loading messages or other problems in dmesg.

If you’re using PureBoot (or want to switch from SeaBIOS), you could instead update to the latest PureBoot firmware with coreboot_util.sh. Blob jail is enabled automatically for Intel ax200 cards by default, even if you didn’t get it from us. You can use Basic mode if you don’t need tamper detection.

3 Likes

that worked!!! Thanks so much!! nice easy little fix.

2 Likes