Librem 14 - Micro SD Port stopped working

Trying to copy photos onto my mashing using Micro SD port. Has worked before, but not it can’t read and Micro SD card I put into it… Any ideas?

For a start, confirm that the uSD card is readable in another computer.

What is the capacity of the uSD card? What file system is on it?

Look at logs on the Librem 14 for error messages in an attempt to understand where the problem is occurring.

Is it a uSD card reader in the Librem 14 or an SD card reader? If the latter then you must be using an adapter, in which case eliminate the adapter as a potential failure point by trying a different adapter.

Workaround is: buy USB card reader dongle. Cost: bugger all.

1 Like

The card is visible on other machines. (I’ve tried multiple Micro SD cards that work on other devices, but not mine.)

Size: 256GB

Its the built-in reader on the L14.

What file system is on it? Probably exfat given the capacity. (Obviously you will need to answer that question from one of the other machines where the uSD card does work.)

Look at logs.

Is the built-in card reader in the Librem 14 a uSD card reader or an SD card reader?