Librem 14, screen brightness

Many times when I open up my Librem 14 after letting it sit closed but on for a while, the screen briightness is quite low.
Using the F6 does nothing. It works for volume but does nothing to screen brightness.
So I have to go into Settings/Power to get the brightness up somewhere reasonable.

Also, why does all text anywhere look like it’s on some kind of late 90s message board?

I find that F6 does not work on the login screen; it’s only after I’m logged in that I can do anything. Is that your issue?

And you need to say more about the text. What setup are you using? You can change the default system font in the settings; have you tried that? Can you post a screenshot?

1 Like

No fully logged in. Everything is going it’s just very dim sometimes and i can’t fix it without going to settings.

hold on on the other part

I don’t see anything about a default font in settings, so no I have not tried. What am I missing?

Here tho:

I had the problem that after a resume I was not able anymore to control the brightness via Fn F5+F6 keys.

The problem has been solved by installing:

In case your are running on Ubuntu/Debian/PopOS

In PureOS you should be able to install it via apt.

Hope that helps.


Thanks for sharing, that was helpful for me. Now with librem-ec-acpi kernel module installed brightness control keys are working properly even after suspend.

1 Like

@milabs I am happy that my suggestion help you resolving your issue. One thing I have noticed is, that after installing librem-ec-apci my external 27" Display was not recognize anymore over usb-c. I don’t why.

Just wanted to let you know in case you are working with an external display.

Thanks for letting know. I haven’t tried it with any external screen so far. But I have another problem with wifi which stops working after switching off/on kill switch. I’m going to create a separate thread for that, though.

I am running Ubuntu on my Librem 14 (yeah dumb idea but I need to be able to share screen on Zoom for work and couldn’t find a reliable workaround that wouldn’t break my updates). I went to that link and could not find the actual deb file to download and install using dpkg. The file name just reloads that page. Because I am not using PureOS I couldn’t install it using apt-get

Okay so I extracted the deb and installed the file as per the instructions (now marginally more literate on how to do this). It made no difference. So I removed it. I did install the EC firmware update via the PureOS ISO image technique on the PureOS website. It still happens. I can fix brightness from the control at the top, but not the dedicated keys.