Librem 14: USB-C failure - need suggestions

Hi all,

I’ve run into a problem with the USB-C port on the right side of the Librem 14.
I understand that this is the one that should accept power delivery and provide display out. Neither of those functions have worked since day 1 of having this machine, but while it served as a USB port, I wasn’t too concerned. Now, however, it doesn’t recognise any devices connected to it.
(I’ve treated this laptop like royalty, so there’s no physical damage)
I’ve updated using the EC tool (v.2.5_2021-10-28) and have updated Pureboot to v20 using a stock image. No change.
Is there some script available that I might be able to run to determine the nature of a hardware fault? I’d prefer to try to diagnose/repair here rather than ship the machine back to Purism.
Any thoughts would be much appreciated before I open a support ticket.
Thanks in advance!

For info:
Output of ‘lsusb’
Bus 002 Device 002: ID 05e3:0749 Genesys Logic, Inc. SD Card Reader and Writer
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0489:e076 Foxconn / Hon Hai
Bus 001 Device 005: ID 0bda:5830 Realtek Semiconductor Corp. USB2.0 camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Output of ‘lspci’
00:00.0 Host bridge: Intel Corporation Device 9b51
00:02.0 VGA compatible controller: Intel Corporation Device 9bca (rev 04)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Comet Lake Thermal Subsytem
00:14.0 USB controller: Intel Corporation Comet Lake PCH-LP USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH-LP Shared SRAM
00:15.0 Serial bus controller [0c80]: Intel Corporation Serial IO I2C Host Controller
00:1c.0 PCI bridge: Intel Corporation Device 02be (rev f0)
00:1c.7 PCI bridge: Intel Corporation Device 02bf (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device 02b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Comet Lake PCH-LP LPC Premium Controller/eSPI Controller
00:1f.3 Audio device: Intel Corporation Comet Lake PCH-LP cAVS
00:1f.4 SMBus: Intel Corporation Comet Lake PCH-LP SMBus Host Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake SPI (flash) Controller
01:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Non-Volatile memory controller: Sandisk Corp Device 5019 (rev 01)

I don’t know if something is missing from these outputs because I don’t have a fully-functional L14 here to compare it with. As I said, any suggestions would be great!

1 Like

Plug something into that port and run dmesg, see if it mentions an error.

Thanks for the suggestion Gavaudan.

It seems that it can’t see it at all.

I ran dmesg, then plugged a USB stick (the Librem Vault type) into the functioning USB-C port (left side), then removed it, then into the non-functioning one on the right, and there’s no entry for it in dmesg.

The pertinent bits are here:

Plug into good USB-C port

[ 2919.120235] usb 1-9: new high-speed USB device number 4 using xhci_hcd
[ 2919.269428] usb 1-9: New USB device found, idVendor=13fe, idProduct=6300, bcdDevice= 1.10
[ 2919.269432] usb 1-9: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2919.269435] usb 1-9: Product: USB DISK 3.0
[ 2919.269437] usb 1-9: Manufacturer:
[ 2919.269438] usb 1-9: SerialNumber: 070099A07B392935
[ 2919.271007] usb-storage 1-9:1.0: USB Mass Storage device detected
[ 2919.271312] scsi host1: usb-storage 1-9:1.0
[ 2920.289511] scsi 1:0:0:0: Direct-Access USB DISK 3.0 PMAP PQ: 0 ANSI: 6
[ 2920.289959] sd 1:0:0:0: Attached scsi generic sg1 type 0
[ 2920.291002] sd 1:0:0:0: [sdb] 60555264 512-byte logical blocks: (31.0 GB/28.9 GiB)
[ 2920.291339] sd 1:0:0:0: [sdb] Write Protect is off
[ 2920.291342] sd 1:0:0:0: [sdb] Mode Sense: 45 00 00 00
[ 2920.291635] sd 1:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[ 2920.361763] sdb: sdb1
[ 2920.389570] sd 1:0:0:0: [sdb] Attached SCSI removable disk

Unplug from good port

[ 2932.640732] usb 1-9: USB disconnect, device number 4

Plug into bad port


I’m going to have to contact Purism directly aren’t I?!

Seems like you might. You can try a different USB device if you haven’t already. It shouldn’t make a difference, but I’ve seen some strange things happen before.

1 Like