Librem 14 v1 fan doesn't work

EDIT: Nevermind, the fans are moving, they’re just very quiet and the CPU can get pretty hot. However, my SSD is overheating in normal workloads, but I’ll have to find some way around that (a laptop heatsink, some kind of throttle, I’m not sure) since it’s not an issue with the fans.

The fans on my Librem 14 v1 don’t run at all. I’m not sure if they ever did. I run Debian testing.

I updated coreboot+SeaBIOS (4.16-8-gf88975265a) and Purism EC (1.7_2022-04-27) but no luck. I ran sensors-detect but it can only find the CPU thermal sensor and pwmconfig says “There are no pwm-capable sensor modules installed”.

I’m not sure if it’s an issue with my laptop or I’m doing something wrong. The temps get way too high in some situations and my laptop freezes. Can anyone offer any advice?

I would be contacting and it may help to mention what temps you are seeing. (I think most current Intel CPUs are rated to run hot e.g. 100°C. So what is “too high”? That’s not to say that I would want my CPU close to boiling my cup of tea.)

1 Like

My SSD or CPU can reach >70 C even under moderate workloads.

While I am concerned about the kind of damage this may do over time, I’m more concerned that my computer freezes up (not just the UI, Alt+Ctrl+F1 doesn’t work). One time even the power button failed to respond and I had to unplug the battery.

Also I just noticed “sensors” claims my CPU fan is running at 1000-2000 RPM, but the fans are still.

I think that you probably need a kernel driver for the EC, which you can find here:

I had similar problems with the 2012 MacBook Pro until I installed a great little daemon, mbpfan, that enabled and controlled the fans.

that driver has absolutely nothing to do with fan control (currently), it only allows setting of the battery charge limits and the RGB LED

Sorry. Oops. I guess I read the code too quickly. I got the impression that it made hardware sensor temperatures available as well.