Librem 14: WiFi works while installing OS's, but not when after

I received my Librem 14 a couple of weeks ago, and have yet to succeed using it haha.

Installing NixOS make it not boot. I currently have the UEFI firmware flashed on it - from the well known Chromebook repository.

I’ve resorted to installing Ubuntu, and my latest attempt Elementary OS which is surprisingly pleasant.

In both of these, I can connect to WiFi just fine when in the installer from a live USB stick, but not when actually booting from disk. So it obviously works, but somehow wireless just doesn’t show up in the settings page.

I’m writing to ask more experienced Linux users for some help with how to debug this.

I have the standard network card - if you all recommend I can buy a different one and perform some surgery :D.

What I’ve tried so far

  • Ensured that the hardware switch actually is set to ON - light is shining.

  • Installed different operating systems - NixOS (didn’t boot), Ubuntu, and Elementary OS (both no wifi when booting from disk - but when booting from USB stick it works)

  • Googled and read this forum - but I don’t find any similar issues solved.

Live boots typically have drivers preconfigured but they’re generic, and sometimes they don’t make it into the installation. But then you end up in this weird situation where you need to update the operating system and/or kernel, but you can’t unless you have ethernet.

So if you buy anything, get a usb-ethernet adapter and run a system update. Or, if you’re feeling froggy, figure out what WiFi card you have, get its driver from a different machine, and manually install it.

Reasonable generic advice but the Librem 14 has an ethernet port - so the drivers, if required and available, should be able to be downloaded normally, without the hassle of getting a USB GbE adapter or moving the drivers in via USB flash drive etc.

What you say would apply to the Librem 13 and Librem 15, as I understand it.

Check that the system time is set correctly.

Then … yes … run a system update.

Make sure that the ethernet is connected to the local network. Make sure it is configuring correctly and working. Do an update.

As this is a relatively newly purchased laptop, it may well need sudo apt update first and then sudo apt upgrade and there may well be a large number of updates to apply.

Testing the WiFi will be complicated by the presence of the ethernet i.e. once the updates are all done then you would need to disconnect the ethernet.