Librem 14 won't boot bc of inaccurate clock

How do I change the clock time from within the BIOS? The battery must have been completely drained, it thinks it is 1970-1-1 and some gpg key is not accepted because it was signed in the future

it seems that the hwclock command included in the Pureboot kernel doesn’t support the --set --date option needed to do so, so you’ll need to force an unverified boot and then the clock should sync when the OS boots.

drop to emergency/recovery shell

date -s “2 OCT 2006 18:00:00”

hwclock -w


that should help

1 Like

Thanks, it worked, except the time format was not recognized. date -h revealed among other things:

Recognized TIME formats:
    YYYY-MM-DD hh:mm[ss]

hwclock -w worked as expected

sorry for that for that issue, i never remember it,
glad that i partially helped.

your problem was probably caused by cmos clock lose power.
so it started unset , so setting system time, then forcing kernel to set cmos clock (hwclock call) will solve issue,
however if problem reoccur in future - check battery,
in l14 cmos is being powered from battery. if it got discharged to low then battery controller will cut the power to avoid deep discharge of battery which would end with battery failure.

Reminds me of a backup product on the HP3000. Not only did it require the HPSUSAN and the HPCPUNAME, and if your clock was off, it also not run.

Additionally it also counted the number of processors. If you had lost a processor and were running on less you needed a temporary license key until a replacement came in. (The heat sink on the last model of processors were five inches tall.)