Librem 15 external monitor 2560x1920 and other rants


#1

When I first started using the librem 15 I was surprised that my ultra-wide external monitor’s resolution of 2560x1080 was not available both in PurseOS and elementary OS. (Pure OS bombed on day one so I switched to something else) What a bummer!

The display on the librem 15 is weird in general – you can barely read your grub entries because they appear so tiny. I don’t fully understand the benefits of having a very high resolution for a tiny screen but the LoDPI scaling factor in X really helps except some of the application icons appear gigantic in elementary OS.

Anyway, back to my external display! Maybe 2560x1920 it not a supported resolution of the intel HD Graphics 620? I do not know, I searched intel’s site but could could not find the information I was looking for, but I did stumble upon this article that explains how to add a missing / custom display resolution. I followed the instructions (plugging in 2560x1920 rather than the resolution used in the article) and I can now use the full width of my monitor! yay! Hopefully this doesn’t damage the intel GPU in some way.

I know this post seems very critical but I really mean to provide constructive criticism. I want Purism to succeed and I think identifying the bumps in the road is crucial.

I’m both excited and sort of cringing as I wait for my librem 5 to ship.


#2

In my case the exact commands I ran were:

sudo cvt 2560 1080 60
sudo xrandr --newmode "2560x1080_60.00" 230.00 2560 2720 2992 3424 1080 1083 1093 1120 -hsync +vsync
sudo xrandr -q
sudo xrandr --addmode HDMI-1 2560x1080_60.00

Then the new 2560x1080 resolution was available in the displays screen:


#3

lol well I had it working… I had to rerun the commands after rebooting and now I have a choice between an external monitor with insanely huge font or a built-in display with extremely small font.


#4

Do you have to use a refresh rate of 60 Hz?

That is limiting some of the possible resolutions if using Intel HD Graphics 620.


#5

Just update Coreboot (bios). It fixed my issue with my beautiful 2560x1440 display.


#6

No, I don’t think so.
But the resolution of 2560x1920 is never an option until I add it via xrandr.


#7

Thanks I’ll try that. Hopefully it doesn’t brick my device.


#8

That worked! Thanks again!