Librem 15 stuck at 802.11g (54 mbps) -- can not change to 802.11n (150 mbps)?


I just enable the wifi hotspot at home to 802.11n. Pretty much instantly, most of our smartphones switched to the higher speed of 150 mbps. However, my Librem 15 laptop stayed at 54 mbps.

I have moved the laptop to pretty much next to the hotspot. Still it clings to 802.11g
While the smartphones further away continued to connect at 802.11n

I’ve tried forcing it to switch to 802.11n (sudo iwconfig wlp2s0 modu 11n).

However, it claimed that “11n” is an invalid argument.
Turned out when I executed “sudo iwlist wlp2s0 modulation”, I got error message “unknown modulation information”

Here’s output of “modinfo ath9k” :

parm: nohwcrypt:Disable hardware encryption (int)
parm: blink:Enable LED blink on activity (int)
parm: btcoex_enable:Enable wifi-BT coexistence (int)
parm: bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm: ps_enable:Enable WLAN PowerSave (int)

Screenshot of the wifi hotspot’s GUI can be seen here :
(my laptop is


lspci |grep Atheros

02:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)

Does anyone knows how to make Librem 15 switched to the faster 802.11n wifi protocol ?

Do let us know.

Thanks !

Forgot a few details :


cat /etc/debian_version



uname -a

Linux HSZ 4.3.0-1-amd64 #1 SMP Debian 4.3.5-1 (2016-02-06) x86_64 GNU/Linux


iwlist wlp2s0 freq

wlp2s0 32 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 36 : 5.18 GHz
Channel 40 : 5.2 GHz
Channel 44 : 5.22 GHz
Channel 48 : 5.24 GHz
Channel 52 : 5.26 GHz
Channel 56 : 5.28 GHz
Channel 60 : 5.3 GHz
Channel 64 : 5.32 GHz
Channel 100 : 5.5 GHz
Channel 104 : 5.52 GHz
Channel 108 : 5.54 GHz
Channel 112 : 5.56 GHz
Channel 116 : 5.58 GHz
Channel 120 : 5.6 GHz
Channel 124 : 5.62 GHz
Channel 128 : 5.64 GHz
Channel 132 : 5.66 GHz
Channel 136 : 5.68 GHz
Channel 140 : 5.7 GHz
Channel 149 : 5.745 GHz
Channel 153 : 5.765 GHz
Current Frequency:2.442 GHz (Channel 7)



wlp2s0 IEEE 802.11abgn ESSID:“xxxxxx”
Mode:Managed Frequency:2.442 GHz Access Point: F4:EC:38:E9:A1:A8
Bit Rate=54 Mb/s Tx-Power=19 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:29 Invalid misc:36113 Missed beacon:0

I think there’s driver problem.

The built-in wifi could never switch to the faster 802.11n mode, and it can not be forced.

It’s always stuck at the 802.11g mode (54 mbps)

I tried plugging in this old USB Wifi adapter :

And it straight up goes to 802.11n ! 150 mbps, very nice.

iwconfig wlxa0f3c1158a01

wlxa0f3c1158a01 IEEE 802.11bgn ESSID:“Graha34” Nickname:"<WIFI@REALTEK>"
Mode:Managed Frequency:2.442 GHz Access Point: F4:EC:38:E9:A1:A8
Bit Rate:150 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Encryption key:------- Security mode:open
Power Management:off
Link Quality=81/100 Signal level=-46 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

So in the meanwhile, looks like I’ll be using this little USB wifi adapter. It’s just much faster.

@OP. You must have a defective wifi module. I have the very same Atheros AR9462 card in my laptop and it does 11n wonderfully. It’s dual band and also dual stream. Very fast, comparable to the Intel N6230.

Very interesting - I think you are correct !

Not only the built-in wifi is unable to switch to 802.11n - it also disconnects pretty often.

Quite infuriating when a lot of your time is spend on SSH console :slight_smile:
(I do use screen/tmux/mosh, but it’s still pretty annoying)

So yeah, I think the wifi module in my laptop is defective.

I think I’ll just use the USB wifi dongle, and use the mPCI port for something else…probable eGPU #yum

I received my Librem 15 this week and I have the same problem, no N connectivity only G

So, it’s possible we both have defective WLAN cards, but maybe there’s an other problem.


When I checked the inside of my Librem 13, I found out that one of the antenna cables was pinched in the assembly at about 15cm from the miniPCI adapter. Only the outer insulation was slightly damaged, so no real issues. Now, I don’t know how the Librem 15 is assembled, but you might want to check the integrity of the cables.

Maybe, before opening it, you could try to check what happens if you keep an AP very close (but not less than, say, 2 wavelengths, 25cm) to the antennae. If that doesn’t give you 802.11n, you can most likely rule out a wiring problem.

дядя Вова

Hi дядя Вова,

I have already opened up my case, but I’ll give the wireless card and it’s leads a closer inspection this time.