Librem 15 Tilex Terminal Bug, Terminal Will Not Reconize User PW after Pure OS first update

Greetings Liberty Lovers!

I tried the Official Purism Tech Support Channels, first.
I asked tech 3 simple questions and they do not seem to comprehend the issue.
I also researched these topics, online to no avail.
Reaching out to the community for help.

My Problems-

  1. Terminal issue with Tilex code, warning window pops up when used for first time.
  2. Instructs user to go into terminal and change the config files to assure it functions properly later. (failed to heed warning- did not reconfig Tilex Terminal as suggested)
  3. Terminal worked fine in su and root before OS updated.
  4. PureOS initial update broke Tilex Terminal.
  5. BUG- Terminal no longer can use Super User as it does not recognize the User name and PW. Can long into OS. Can not access su through Tilex Terminal since PureOS has updated.

New out of box Lib15 initial set up, (took out of box whilst on vacation) Bought the Lib15 for secure travel laptop.

  1. Secure Core Boot installed, PWs installed through PureOS initial set up procedure.
  2. I used the Tilex Terminal as su and root with no issues, initial tweaking.
    Warning window thrown on initial start of of Tilex Terminal suggesting changes to the way the terminal updates and relates to OS updates in future to avoid future stability issues.
    (unfortunately I don’t remember the exact details of the warning message, but that was the general idea)
  3. Did not follow the warning window instructions to change the Tilex Terminal Config settings. I was on vacation and figured I would revisit the issue and reconfig Terminal later, if issues arose…(not anticipating being locked out of the su and root access in terminal)
  4. Notice saying PureOS needed update on next boot up. I let OS do initial updates.
  5. During the update phase a pop window appears, asking for the encryption PW used for encrypting my drives. Not sure if this is every time the OS updates or not, or just the first update…will be a pain in the ass if its doing that every time the OS updates.
    Note: No warning about this fact as your setting things up for the first time. Use a PW you can remember, not a computer generated random string of letters and numbers!!!
    (There is no copy/paste ability in this phase of boot)
  6. Hair raising, sweating bullets time… trying to get the correct dive encrypt PW entered, twice, sitting next to the pool…not fun.
  7. I went back into the terminal to change the PWs to something simple until I get back home and finish tweaking the OS to work the way I expect it to. Tilex terminal now does not recognize the user PW. I also tried the PW that I encrypted the drives with, no go.

****Issue, I can not issue commands in the Terminal as super user or root now, since the OS updated. I researched the issue with the terminal, evidently it quits working after the OS updates and has software issues with passing over certain parts of the code, which affects passwords…(my bad for not taking the time to avoid this issue by doing the re-config of terminal, as instructed, from the git-go)

  1. Has anyone else experienced this Tilex Terminal bug and what is the work around?
    Is there a backdoor into the Tilex Terminal with a default PW so it can be reconfigured?
  2. Should I try deleting and reinstalling the Tilex Terminal and setting it up properly next time through the OS itself using the Software App?
    Better yet!
    **3. I noticed there is a small hole on the bottom of the Lib15 laptop that says, “reset”.
    Does anyone out there have experience with this reset feature and used it? What happens when you shove a paper clip in the hole? Could it be that simple to return to factory default and start over? That would be awesome!

As this is a new laptop and I don’t have much tweaking involved in this distro, I have no issues starting over from scratch and avoiding this land mine next time.

Daily drivers are RHEL, Fedora, Qubes, ParrotSec.

Thanks again in advance for taking the time to read this.

A lot to unpack here. Regarding your issue as superuser: Have not experienced any of these problems at all. Important thing to check first is if your user is in the sudo group. Go to the terminal and type


where USERNAME is the name of your user. It should list all groups that you are a member off. First thing to check: is sudo in that list. If so, good :slight_smile:

If you cannot run sudo su in Tilix, have you tried another terminal? If it is indeed related to that patch that you need to apply to Tilix (sorry, it’s been a while for me), then you should be able to do that in any other terminal too. Could just install xterm for example from the Software app.

That’s kind of the point. You want your drive to be encrypted when you turn your computer off or reboot, otherwise, encryption is kinda useless… My way around it: I have a very long and complicated passphrase, hope that I won’t have to use it. In addition I use a GPG key (LibremKey or YubiKey work) to decrypt the drive. If I loose my key, I’m gonna be entering my passphrase for a while… If I don’t, I only enter a short pass phrase plus a hardware token to decrypt the drive. Still takes quite some guesses to guess my short password and can repeat very fast, so brute force attacks are not really feasible.

1 Like

Thanks for the help,

Called that one correctly, “no such user” in Tilex.
Installed “Termit Terminal”, from software center, ran ```

Same output, "no such user"......
Think I broke something, somewhere, somehow......

Any thoughts on what the "reset" hole in the bottom does?

You could just reinstall PureOS from a USB drive.

I am hoping its as easy as sticking a paper clip in the back of the laptop and starting the initial set up phase over again. This time updating the Tilex Terminal first.
Seems much easier to me, maybe I’m wrong, not sure.

Before doing any radical step (such as OS reinstall) you can try wiping your user profile (and settings) by doing

rm -rf ~/.config/*
rm -rf ~/.local/share/*
rm -rf ~/.cache/*

and then log-out and log-in again. Note that it may have unexpected consequences when app uses both xdg dirs and app-specific dirs which are then going out of sync. Also it will wipe your keyrings (which are stored in .local/share/keyrings).

1 Like

Not sure about the reset button, but I highly doubt it’s anything else than cutting power from the machine and thus resetting it, but wiping the hard drive and resetting all settings would mean it must have a clean system stored somewhere. That’s just not going to be it.

So your user does not exist… what user are you? Can you run


That should give you your current username… is that the username that you would expect? If not, can you run that one with the groups command?

1 Like

I think I would like to address the aftereffects first, like Keyrings, before I take that shot, but I’m willing to explore all options.
The goal is not to make things worse.
How is that going to affect the drive encryption?.
Not being able to access the drives, is going from a minor issue to a major one.

No this keyring is a password manager, not affecting drive encryption

Thanks, I will give this a try and get back.
I don’t know how Purism sets up their laptops.
If they configured it in such a way that when you stuck in the paperclip and pushed reset. When you restarted, it triggered a boot menu option to boot from a fresh install OS on a partition on the drive…
Once back into the OS again, you access the partition with the old OS, pull out what you need and shit can the rest. Files are kept on my second SSD anyhow.
When Pure OS configures the OS again its on a mirror of the fresh install.
Seems very doable to me. Pretty much the way you reset a tablet back to factory default in Android.
This is supposed to be a secure OS on a secured laptop.
You can do a factory reset on a windows or a system restore, maybe I am crazy, but I am not sure why it could not be done in PureOS.
Especially because of the secure core boot feature on this laptop and how bad that can go, really quick like… if you don’t use a simple to remember passphrase. Seems pretty easy for others to make the same mistakes I made on my initial set up.
Seems it should be just as easy to fix it when all else fails.
Just cant find anyone yet who knows exactly why its there and what it does. Seems really strange to me.

There’s one way to find out…

True, I run into smoke and flames for a livin, why not…
If I see smoke and flames, I’ll be prepared…

If I run into any lil Linux Gremlin’s, not so much…

Stay tuned…

Cool beans, losing the drives would be baaaaad…

Sorry for the delay, wanted to get back home where I could focus better on what I am doing.
I went into the Termix Terminal and entered the command ```

It pulled the same user name that I set it up with and the same UN I logged into PureOS with. 
When I try to log in as su I get this; "Authentication Not Recognized." when I enter the PW.

I did a quick search and saw a suggestion to try in the terminal:

pkexec passwd $USER

and change your password to something that doesn’t use special characters (as in, no umlauts or anything). Seems to have worked for them.

1 Like

Just to make sure: How do you log in as su? It should work if you log in by typing

sudo su

This is probably what you’re doing, just trying to make sure.

1 Like

Finally got a few minutes to come back and address the feedback folks provided.
You hit the nail square on the head, I entered the command into the Tilex terminal, a window popped up in the OS, it asked me for my current PW to make changes, which I entered. It took that and let me change the user name PW in the Tilex terminal to something without any special characters. It seems to have accepted the new PW and is happy so far.
I will next attempt to change the PW for the encryption of the drives.
Here’s how that gets done.
I guess someone else will get to stick the paper clip in the back of their Librem 15 now. I still would like to know what it does.
Thank you very much and wishing you a great New Year!

1 Like

The issue comes in the terminal, I am working in the terminal and some commands require su to make changes. The terminal prompts me to enter the pw for su…the same one I just logged in to the OS with, which worked just fine.
I entered that pw and it says its the wrong one, therefore the terminal would not let me make any serious changes to my OS.
I have not gone directly into the Tilex terminal and enter the sudo su command.
I believe that the issue was with my pw and special characters. I broke some old rules concerning Linux and the proper way to do pw’s.
Thanks again for your help.