Librem 15v2 power issues

My beloved Librem 15 is not having a good morning. It’s completely unresponsive and showing some interesting behaviour with the system state indicator light.

Can’t be certain whether I completely shut it down or put it in hibernation last night, but when I jumped on this morning the state indicator light was slow pulsing as if it was in hibernation.

  • Tapping the keyboard would not wake it up
  • plugged in power and the orange power light comes on as expected.
  • Tap more keys on the keyboard but still no response.
  • Press power button - no response.
  • Give it some more time to charge, still no response.
  • Try to power-cycle by holding down power button - continues slow pulse
  • Holding on power button seemed to keep the power light on for slightly longer than the slow pulse but would still turn off again.

At this point I wonder if it’s a power issue, so:

  • Remove charger and battery for 5 minutes.
  • Reconnect charger without battery - the status light turns on and remains on as if the system is booting but it seems that no power is getting to the screen.
  • Power-cycle to see if I can get the screen to power up - still nothing.
  • Reconnect battery and charger - again pressing power button activates status light as if it’s booting up but no power to laptop screen.
  • Attach an external monitor to see if its just the built-in display that’s broken - nothing.

Despite no working display the system status light does remain on so perhaps the system is booting?

  • Tried to enter disk encryption password
  • Screens stay blank / powered down
  • System is not connecting to network so presumably has not booted

Any suggestions on what to try next? I’m generally not a hardware guy but happy to tinker with some guidance.

PS. I have loved this laptop since I first got it in 2016. This is the first real issue I’ve had from the initial line of a new product - that is an achievement in itself. I’m happily waiting for my Librem 5 as the necessary software development and hardware iterations continue. Big props to Purism for all your work creating real open hardware alternatives.

It can easily be a RAM module issue, do you perhaps have a spare module you could try?


Bingo, thanks Mladen!

Thankfully it was rocking 2x8GB modules and one of these was the offender.

Time for a memory upgrade while I think :slight_smile:

1 Like