Librem 15v3 black screen

Heya, since yesterday quite often when booting or resuming from hibernation the screen of my librem 15 is staying black - no purism logo from coreboot, however, sometimes, once progressing past initramfs the screen does come up (Running Archlinux), but not always.

Is this a known problem? Should/could updating coreboot fix it? If so, how would you do so? Thank you for help!

Yes, please try with coreboot update, follow instructions from https://puri.sm/coreboot.

Unfortunately that didn’t do the trick - quite often when booting the screen is still black throughout bios and initramfs (making password input hard)

Since you are running Arch Linux: did you perform system update recently?

I have similar or same issue.
Setup: Librem 15v4 with 4k display, running PureOS amber with defaults: Gnome and Wayland.
Started showing up after I reduced resolution from 3840 x 2160 to 1920 x 1080 for my user sessions. But that may be bogus, as at about the same time an OS update was also done. Unfortunately, I can’t pinpoint the exact time when it happened for the first time.
Symptoms:

  • Various boot stages are invisible (black screen + backlight on).
  • system comes up with 4k resolution and presents a login screen. But often this is also black.
  • After logging in the graphics mode is changed to 1920x1080, and this sometimes fixes the issue.
  • Changing consoles after login (effectively switching modes between 4k and 1920x1080) results in black screen or fixes black screen, randomly.
  • Locking up gnome session with super-l key combo switches screen of (backlight goes off also), bringing screen back with spacebar fixes the issue, but again, not always.
  • Upgrade from coreboot 9 (as shipped) to the latest version did not fix the issue.
  • OS is kept up to date (did last update yesterday), and the issue persist.
  • First time I noticed it was after boot. I kept computer running for few hours, then pressed a reset button (the one at the bottom, operated with a pin through a chassis) hoping that warm boot would have the issue fixed, but it did not make any difference afterwards.

It seems that graphic mode changes are not done correctly. Don’t know how to even start debugging this. Is it bios, graphics card, kernel driver, wayland or gnome issue?

Sorry for the late reply, been very busy lately!

Yes, there were arch updates briefly before that happened (xorg even), however that shouldn’t have changed that coreboot is able/unable to turn on the screen.

It appears that the problem happens mostly after quick reboots, if the laptop is turned off for like a day or so the screen often comes on AFTER initramfs (so still no coreboot).

There is no obvious damage to the hardware when opening it up.

Alright, the issue persists with PureOS, so it doesn’t seem to be an Archlinux-related problem.

I tried un-and-replugging the display from the motherboard and the screen seems to come on for now! (that is, two boots). As the issue was rather random only time can tell if it actually is fixed, though. I’ll keep this thread updated.

1 Like

Unfortunately the issue does not seem to be fixed: Yesterday when resuming from sleep the screen was suddenly flashing, after a reboot it doesn’t come on at all anymore, also within bios.

1 Like

Having the same issue with my Librem 15v4.

Were you guys able to fix that annoying problem?

1 Like

Contact purism support at: support@puri.sm

yeah, I sent you an email an hour ago

did someone fix that issue? The support of purism is was not helpful at all.

1 Like

Did you or anyone fixed this meanwhile?

I have the same problem with Librem 15 v4, and for me it looks like a coreboot problem, because after reboot sometimes i doesnt even see the logo of pursim/coreboot, it stays black.
The only trick i know to get out of the black screen is to get into the desktop by login (blind), then shutdown the lit or press fn&esc, wait for a few mins and get out of sleep mode again; but this isnt comfortable at all ofc.

You better say what coreboot version in that case. Are you running the latest?

2 Likes

Yes, i tried the latest precompiled version and also build from source with the coreboot_util.sh from purism, and got the same result.

This issue is also affecting my Librem 15v4. Updating to the latest coreboot release seems to have helped slightly but the problem is still there, and occasionally when opening the laptop lid after periods of inactivity the screen will blank. I’m hoping someone at Purism is working on this issue, it is significantly affecting the usability of the laptop.

1 Like

For anyone looking for more info, this has affected me on multiple different linux distros, using both wayland (gnome, sway) and xorg (i3). Symptoms are identical to what @Dwaff reported above. After talking to support, they advised me to check the screen connector. There didn’t seem to be any obvious pinching or twisting, however unplugging and re-plugging the connector seemed to slightly reduce the frequency of the screen blanking. Customer support decided that the most likely culprit was a defect/pinch in the screen connector in the screen part of the case, and then informed me that since my year of warrenty had passed I was out of luck. I may try to open the screen case in the future, but I don’t want to damage the laptop as it is my daily driver right now.

i feel you, still having the same problem. :confused: